Question

New build on Black Screen

I just got done building my first PC, however when I attempt to turn it on I get stuck at a black screen, nothing happens, the monitor doesn't even recognize that the computer is there. This is what I'm working with:
Asus Z97 Deluxe Motherboard
Intel Devil's Canyon i7 CPU
I'm just gunna hit paste for the GPU XFX Radeon R9 290 R9-290A-EDFD 4GB 512-Bit GDDR5 PCI Express 3.0 x16 HDCP Ready CrossFireX Support Double Dissipation Edition
1000w power supply
Windows 10 (not installed just sitting in disk tray)
Seagate Barracuda 3TB 64MB cache hard drive
Corsair H60 hydro cooling (it's a CPU cooler and a fan)
Rosewill Challenger Case
I have an SSD
4K supported ASUS 28in Monitor
2 8GB Ares Series G-Skill RAM

I read all of my manuals, watched online guides, and did a TON of research before putting this build together and ordering it, everything appears to be installed properly, however the LED DRAM_LED MemOK is solid red and I can't figure out why. I don't see any other issues the inside of the computer, but I can take photos if necessary.

Thank you for looking at this for me! I'm kind of freaking out.

Discussion is locked
Follow
Reply to: New build on Black Screen
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: New build on Black Screen
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Did you put it all together at once or did you?

Did you build it up slowly. For example on cardboard I can place the motherboard, PSU, on stick of RAM and CPU+HSF and test it to come up to the BIOS using the onboard video? If you used a case or more than these parts you built it too fast.

There's also a note of a minimum version BIOS of 1008 for this board and that CPU. Is the maker/seller documenting this is ready to go?

- Collapse -
I think I rushed it

I put it together all at once. Should I dismantle it and build it over again slowly as you suggested?
Apparently I didn't do enough research, how do I check if the maker/seller has it documented as ready to go?
As I said, first time build, I thought I had done everything correctly but was apparently wrong and apologize for lack of knowledge pertaining to the situation.

- Collapse -
Start with the fewest needed parts.
- Collapse -
Answer
What about the oboard video,

did you take a look at that output?

- Collapse -
Answer
Currently disassembling

I'm going to disassemble the computer and build it up slowly, I'll update this post according to my results.

- Collapse -
For a first build this one doesn't need the AMD R9 GPU

That's added laters as we move from onboard to a graphics card build. Right now we need the least number of parts, the least number of connections and checking all jumpers.

- Collapse -
GPU

The GPU doesn't seem to be the problem though, I'm just getting this A2 error code over and over.

- Collapse -
Thank you.

You were right, that was my fault for not understanding what you were saying.

- Collapse -
Answer
Reassembled PC

I have reassembled my computer on my desk without the case, and fixed the previous problem with the DIMM. I'm now getting an error message A2 which means IDE Detect error, and I can't fix it.

- Collapse -
And ONE STICK OF RAM?
- Collapse -
Current Status

Currently on the motherboard there is:
The power supply
2 sticks of RAM
CPU
Corsair cooler
Optic Drive
Internal Hard Drive

When I turn everything on, it now displays on the monitor to go into the BIOS settings and the motherboard reads an A2 error code message. The RAM sticks issue has been resolved, and when booting the LED no longer remains on. The only LED currently remaining on is the BOOT_DEVICE_LED.

- Collapse -
If you disconnect the harddrive,

does the A2 error disappear? If so, set the bios to boot from the optical drive and try it with a disc and see what happen. If it seems ok..then reconnect the harddrive and try again. Good luck.

- Collapse -
Still no

I've tried disconnecting the hard drive, the SSD, and the optic drive in different combinations each time, it tells me the same "Please enter setup to recover BIOS setting" every time.

- Collapse -
That's NEW detail.

I didn't read that error message till now. "Please enter setup to recover BIOS setting" sounds like your next move.

Try BIOS defaults and if they don't stick look around for the CMOS clear jumper. It may be in the wrong spot.

- Collapse -
It works!

The computer works, and I now just need to install drivers and somehow get my GPU to work. Any advice on how to do those things?

- Collapse -
Sorry but

Not much has changed as to PC building, OS and driver installation. If the GPU is not working, why it isn't could be:

1. In the wrong slot.
2. Not powered up (didn't connect power?)
3. Incompatible.

- Collapse -
Thank you!

I'll look into the problems with it, thank you very much for your time and help.

- Collapse -
Keep writing.

If you get stuck, just keep writing. Folks will share what they can.

It sounds like things are starting to pull together.

- Collapse -
Graphics Card problems

Okay so I have everything working great, the only problem is the GPU. I have an XFX Radeon Double Dissipation GPU and I cannot figure how to get it to work. Whenever I connect it to the motherboard I get stuck at boot with a black screen again.

- Collapse -
What PSU do you have

You wrote 1000 watts but if it's some split rail deal maybe it's not up to the task . Also do you have the GPU and the 6-pin and 8-pin connectors seated ?

- Collapse -
PSU

Both the 6 and 8-pin VGA cords are connected to the PSU box and the GPU. Here is a link to the page I bought the PSU from.

- Collapse -
(NT) Link ?
- Collapse -
?
- Collapse -
Cool !

That's eliminated

- Collapse -
Answer
Seagate 3TB. (Monty Python) Run away. Run away.
- Collapse -
Oh wow

My HDD works fine, and after that read I feel pretty lucky that it does.

- Collapse -
My advice is to treat it like a time bomb.
- Collapse -
Here's what I'm going to try

I'm going to update the BIOS according to how the ASUS site says to do it. Does that sound like a good next step?

- Collapse -
Now's the time to do that.

While in warranty!

- Collapse -
Progress

I don't have access to a USB drive at the moment, but I will post the results tomorrow when I have the chance. Thank you again for all the help!

CNET Forums