HolidayBuyer's Guide

Windows Legacy OS forum

General discussion

new app/shortcut icons are always the default icon

by t26l / September 15, 2008 9:35 PM PDT

hello guys and girls

I have a problem with my fresh xp install. I tried to do a slipstreamed installation (SP2 and patches/drivers/tweaks pre-installed) but somehow I'm missing features and have a hard time finding what's wrong. Here's my problem.

Whenever a new file is created, or a shortcut, or even when I browse files on my hard drives, the default windows icon (shell/command/window icon) is the only one I see (and the folder icon is fine) unless I right click and set it to its default icon, in which case it sticks and stays that way.

Is there anyway to re-enable the default icon creation ?

I fiddled with the icon cache, not it (in the Docs and Settings/Regedit too)

My system icons are fine.

Thanks for any help

Discussion is locked
You are posting a reply to: new app/shortcut icons are always the default icon
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: new app/shortcut icons are always the default icon
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by R. Proffitt Forum moderator / September 15, 2008 9:52 PM PDT

That's the clue here. It's a bum slip so go back to non-slipstream and it will work proper. Why break this?

Collapse -
Re: shortcut icons are always the default icon
by Tufenuf / September 15, 2008 11:07 PM PDT

t26l, It wouldn't hurt to try this. Right click your Desktop, choose Properties, under the Settings tab change the Color Quality from 32 bit to 16 bit, click Apply/OK. Now go back and chnge it from 16 bit to 32 bit, click Apply/OK. This will rebuild the iconcache.db file and may correct the icon problem.


Collapse -
by t26l / September 18, 2008 12:54 AM PDT

well, the iconcache does not do anything, and having a slipstreamed XP is an extreme time saver (though from now on I will ghost my drive for even faster restore)

a second symptom is that I need to right-click, assign the default (pre-selected) icon twice to my shortcuts for them to have them appear, otherwise I still get that 'window' icon

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.