Question

Network Printer Issues

Hi all.

I've got a Canon MX700 printer that is plugged into my router. I've reserved the ip number 192.168.0.100 via the router's web interface using the printer's MAC address. So I can now ping the printer from all computers on the LAN and I can get to the printer's web interface from all machines. However, try as I might, none of the computers can add the printer. I've tried from a new Windows10 machine, a Macbook pro and a Ubuntu 18.04 computer. They all time out and claim they can't contact the printer. Any suggestions much appreciated.

Discussion is locked

Follow
Reply to: Network Printer Issues
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Network Printer Issues
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
did you install the printer software?

for each OS?

- Collapse -
Answer
Shared Network Printer
- Collapse -
Network Printer Issue

Cyclops1983: thanks for the link. I've gone through the standard Windows10 "add a printer" routine. In fact, it seems like I've tried every permutation of networked printer options. In no case can the Windows10 machine find the printer. Same for MacOS and Ubuntu.

-jim

- Collapse -
Answer
A thing I run into

The router firewall is blocking the printer access.

Also, is your LAN network 192.168.0.x and the netmask value 255.255.255.0?

Did you do the address reservation so that the address is DHCP'd and not set in the printer?

Post was last edited on May 4, 2018 9:26 AM PDT

- Collapse -
Doesn't seem to be the router's firewall

I turned off the router's firewall but the situation is the same; ping and web connection are fine but printer setup fails.

LAN is 192.168.0.x subnet mask 255.255.255.0.

My router (Motorola SBG6580) doesn't seem to restrict the IP number range for reserved IPs, but I've tried a bunch of them anyway. I've been careful to change what the printer thinks its IP is (via the printer's web interface) when I change the MAC address and IP number through the router's web interface.

Still, it does seem like a network issue as three different OSs' print configuration programs fail to connect.

Jim

- Collapse -
Kind of a stumper.

But there is one last idea before you return it as defective. Be sure to not use the CD that came with the printer. Go get the latest from the printer maker.

- Collapse -
PS. Go back and let the printer do it's own DHCP

If you manually set it up, there is more than the IP and netmask to get right. Just let it DHCP at first.

- Collapse -
But how to get DHCP to work

I can get the router to assign a DHCP number to the printer but then how to get, say, MacOS to follow the changes in IP numbers?

In the MacOS printer setup under the IP tab it requires an IP number. I can enter the one currently assigned but then what?

Thanks for all the responses.

-Jim

- Collapse -
That's very strange.

I've installed many printers and some time over a decade ago I didn't have to input the IP number. I used the printer maker's installer.

- Collapse -
PS. If you assign the IP

Well, there are other entries to worry about. As a test. just go with DHCP all the way as a test.

- Collapse -
BJNP port driver

So here's what happened. While monkeying around on the Windows 10 machine I managed to have get printer recognized. Here's the procedure I used:

->Add printer (Windows was not able to find any)
->Printer That I Wanted Isn’t Listed
->Add a local printer or network printer using manual settings
->Create a new port
->Canon BJNP port
->enter IP address

The thing that’s new here is the Canon BJNP port that allows all this to work. I must have installed it at some point in the process using Canon’s (antiquated) installation software I downloaded from their site. I wasn’t confident it even did anything as the printer still didn’t work when it was done.

The BJNP is distinct from the printer driver; it's a port driver. I’ll have to do some research to get it working on the MacOS and Ubuntu fronts as they still can’t see the printer. Ultimately, if I can’t get those going then I’ll just fall back on sharing the printer off the Windows machine.

- Collapse -
are you sure...

...the printer even works anymore?

- Collapse -
Now this is starting to sound like

How we installed printers over a decade ago. Today we just use the setup .exe from the maker. If one did go back to the old ways, I can see why you might fix the IP address. On our Canon printers today, I don't bother. The printer install and driver figures that out for us.

- Collapse -
yes

As I recall they must open some particular port or ports in the network or router to allow the printer to work, aka BJNP.

Post was last edited on May 8, 2018 8:28 AM PDT

- Collapse -
Since I don't run a firewall on the router.

And if it tries on the Windows PC a popup asks me if it is OK which I tell it OK, this is a non-event here.

The story seems to be moving to how we would install a printer over a decade ago.

- Collapse -
Answer
Well i use a network printer but don't connectect to

router. When i setup the printer it grabs an ip address and I don't have to do anything with the MAC Address. I go to the computers and add printer and it shows up as available. I do this on multiple devices.

CNET Forums

Forum Info