The suggested setting is similar to yours but I wonder if you followed the suggestions.

1. Latest firmware.
2. WPA (check!)
3. Enable SSID broadcast (or many see network drops)

For clarity I could supply a podcast where the advice about SSID being turned off is dismissed as ineffective. So why not set it so your system will work?

Bob