Networking & Wireless forum

General discussion

Network did not assign a network address?

by seafox13 / March 11, 2006 11:02 AM PST

Running a broadband wireless network with Netgear modem/router, two desktops, and one laptop.
Routine run of Spybot S&D today zapped my connectivity, and after three system restore operations, the problem is still there.
It tells me that this problem is occurring because ''the network did not assign a network address to the computer.''
Indeed, running ipconfig shows the IP address and Subnet Mask as zeros.
All other machines not affected, but I am floundering attempting to rectify this problem.
I am running WinXP Home on the affected pc, and WinXP Pro on the other two.
I would very much appreciate some advice on this one.

Discussion is locked
You are posting a reply to: Network did not assign a network address?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Network did not assign a network address?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
services maybe?
by blank- / March 11, 2006 1:03 PM PST

go to the run command and type services.msc and check to see if your DCHP Client service is running, my computer did the same thing and it helped

Collapse -
look here
by Gakada / March 11, 2006 1:18 PM PST

From: Matt DuBois [MS]

[[One SP2 related update to your standard spiel below is that LSPFIX (and possibly WINSOCKFIX) is no longer necessary with SP2. "netsh winsock reset" will reset the winsock catalog to a nice, clean state.]]

How to determine and recover from Winsock2 corruption;en-us;811259

[If you have suddenly lost your Internet connection after removing spy-ware
(such as NewDotNet, and Commonname) the following steps will help restore
your connection. This works for Windows 9x/NT/2000/XP.

1.) Download (by: Option^Explicit)

2.) UnZip (Pay close attention to where the file is extracted
3.) Run WinsockFix.exe.
4.) Click the Fix button.

This program will clean up your TCP/IP connection and rebuild the database.
After the program is complete, reboot and your problems should be resolved.

WinSock Fix
Winsock and TCP Repair Utility
This Utility Restores Registry Keys, that may become corrupt after Removing
the Host Program that
Modified them.]

The Winsockfix Utility will:
1.) Detect your current Operating System
2.) Release the IP address, taking you "Offline"
3.) Reset the TCP stack using Netsh.exe (Windows XP only)
4.) Delete the current Registry TCP and Winsock Values
5.) Import new "Working" Registry Values
6.) Backup any Current "Hosts" file
7.) Replace the "Hosts" file with a default one
8.) Reboot the Computer
================ direct download direct download

============= also available here: also available here:
Dealing with Unwanted Spyware and Parasites
Repairing your Winsock Connection

Repairs Winsock 2 settings, caused by buggy or improperly-removed Internet
software, that result in loss of Internet access

Direct download

Using LSP-Fix to remove Spyware & Hijackers


"Operation Was Attempted on Something That Is Not a Socket" Error Message
When You Try to Obtain an IP Address;[LN];318584

Error message when you try to connect to network: An operation was attempted
on something that is not a socket


Collapse -
Thank you, both. All OK now.
by seafox13 / March 11, 2006 2:58 PM PST
In reply to: look here

I thought about it a bit, and noted the addresses by using ipconfig on the other computers in the network, then manually entered the logical missing address on the affected machine.
Where there's a will there's a way, it seems!

Collapse -
RE: Look Here: From: Matt DuBois [MS]
by chuckster685 / May 4, 2006 2:52 PM PDT
In reply to: look here

This message from Matt giving me WinSock Fix has saved my life.
I don't quite know how NewDotNet got on my machine but I do know that it took a lot work to get if off and then I lost my internet. I tried everything, I was on the verge of reinstalling my Windows partition but I decided to wait till I could use someone else's internet.
This was the perfect post, I typed "network did not assign a network address XP" into Googel and this was the first on the list.
It even stated what I had done to get this problem.
I alway come here first for downloads but now I've even more to thankfull for!
Thank you Matt and thank you CNET!!!

Collapse - corrected my MCE guide problems
by actprime / November 22, 2006 9:26 AM PST
In reply to: look here

Ping OK but Browser faulty. My Windows MCE reported that it could not access the program guide , so it threw away my channel settings and guide data. I restored my machine , messed about with DNS settings . It got so that no browser would work , although i could ping anything . This took maybe 12 hours work.
I used the winsockfix , and MCE started working again . Absolutely brilliant.
I note this in case some other poor soul is fighting MCE in a similar way & it could save them a load of time.

Collapse -
Thanks for the solid tip!
by p_works / January 14, 2008 12:47 AM PST
In reply to: look here

Running XP Pro SP2, WinsockFix.exe restored my wireless connectivity flawlessly. Thanks for the direction.

Collapse -
by E-CYBER / February 2, 2008 10:17 PM PST
In reply to: look here

I was having the same problem with the "network not assigning network address" and WIN SOCK FIX corrected it with no problems. I was working on this PC for a few days even bought a new network card. Well its fixed and I'm going to get my money back, lol. Stocks maybe down at this time but I'm keeping my CNET stock no mater what. Thanks again!

Collapse -
Re: look here
by regexp / February 24, 2008 10:28 AM PST
In reply to: look here

WinsockFix fixed it for me too. I spent hours on netgear tech support line with some helpful reps, but after hitting the end of the road they suggested I contact HP about the network adapter. I decided it would be easier to buy a new one which didn't work either. This fix gave me an immediate connection. Thanks!

Collapse -
Winsockfix RUIN my PC
by boogernator / April 7, 2009 9:51 PM PDT
In reply to: look here

After I restarted my pc (commanded from winsoxkfix.exe) It KILLED my Eset Smart Security 4 and it made my LAN and WLAN connection even worst, i thought this was suppose to fix the assigning network address thingy. Luckily my pc had made a restore point so i restored it to a previous state.

Collapse -
Repairing or restoring a network address
by palmagma / December 28, 2009 3:55 AM PST
In reply to: look here

Thanks a billion Gakada for the Winsock Fix suggestion!
After a long frustrating week getting notices that say: "You might not be able to access the internet . . . . . . because the network did not assign a network address to the computer."
my oldest laptop running Windows XP is back in business and connecting to the internet.
The trouble began when I ran a bit of proprietary software (SYSTEM MECHANIC) intended to speed up operations of my XP operating system.

Collapse -
Similar problems
by ElpPlz / December 28, 2006 9:31 AM PST

Well im having similar problems. Its kind of different though my computer is a desktop and i think his is a laptop then again.
Anyway i tried the suggestions above and they don't work. Im sending out ip packets but im not receiving anything.
Thanks for your help in advance

Collapse -
by ElpPlz / December 28, 2006 10:09 AM PST

another post so i can track this thread =)

Collapse -
Network did not assign a network address?Please tell Solutio
by skfake / April 7, 2008 5:36 PM PDT


I am using a wndows server 2003 OS.
As I format it n connect tom network.
I got error as -->Network did not assign a network address?
Please tell me solution.

Collapse -
Please tell much more.

What exactly did you do on the server (like formatting and installing and configuring)?
What exactly did you do on the client (like formatting and installing)?
Where does the message come up (client or server)?
When does the message appear?
And what is the full text of the message?
What's the structure of your network (including routers, hubs, Internet connection and that kind of stuff)?


Collapse -
If you can connect somehow...
by P.R.IDE / May 11, 2008 10:07 AM PDT

If you can connect to the internet using your modem, try this.(If you are hacking someone else's network, this won't work)

1. Open your web browser and make sure it's working.(then minimize it)
2. Connect to the network, even if it gives you that message.
3. Get the network's default gateway on your wireless connection status.(It is under the support tab)If it doesn't say it, it is probably
4. Type that into your browser's address bar to change your settings.

Collapse -
thanks WinsockFix
by chicagoUser / May 12, 2008 11:33 PM PDT

wow WinsockFix!
After removing a spyware, I lost internet's midterms and I was without internet for about a week!
At first I was a little hesitant and thought I didn't want to download yet another program that migth again screw up with my computer, but after reading all the reviews, I went ahead and downloaded it - into another computer and used a flash drive to move it to my network-less computer Happy
It took just two seconds!! first time rebooted with no connection, second time I re-entered network key and bingo!!
I'm soo happy!!
Thanks CNet & thanks to whoever wrote that program!!!!!

Collapse -
Thanks WinsockFix
by DarcyCaleb / April 21, 2009 3:45 PM PDT
In reply to: thanks WinsockFix

Same for me. I downloaded Windows Updates and driver updates and was super frustrated. This took less than a minute to download and run and bingo! Thanks for the advise.

Collapse -
Have tried the posted solutions without success. Please help
by -Chi-Chi- / May 20, 2009 2:43 AM PDT

The problem is occurring in my pc running Windows XP Pro.
My network consists of an Airport Extreme wifi, 1 iMac (Admin), 1 Old Mac, and my pc. Both macs are able to connect the internet without problem.
In my pc I am using the Asus Wifi-Ap Solo, that came with the motherboard to connect to the network.

Story: Last night I wanted to watch 'The Prisoner' on, however, I live in the uk so could not watch it. I downloaded AnchorFree's Hotspot Shield to hide my real IP so that I could watch it. [When I installed it, my pc appeared to re-discover my wireless connection, although maybe that was supposed to happen]. When I quit Hotspot Shield, my computer said I was still fully connected to the network and internet, however no pages were loading, or email, msn etc.

This morning I reset my network and modem to try and fix this issue. The 2 Macs connected back fine instantly, but my pc showed the "network did not assign a network address" error.

I have done countless reboots, ran Winsock XP Fix, ran ResetTCPIP.msi, set up my network again, and I must say I am stumped Sad
I called my ISP and they said they cant do anything if its just 1 computer on the network that isnt working, fair enough.

TCP/IP properties set to automatic.
DHCP is enabled.
Auto-configuration is enabled.

When I repair the connection and it fails, I go to status and get this:

Subnet Mask: 255.255.0
Default Gateway:
DNS: [Blank]
WINS: [Blank]

From the help section on my ISP's website I found that the 169 in my IP address means that my pc failed to contact the DHCP server.

It has worked fine up until now. Sad

This has been driving me nuts all day, any help will be greatly appreciated.

Collapse -
by -Chi-Chi- / May 20, 2009 7:28 AM PDT

Well I disabled my network password. And now I can connect. Although when I enable the password I am get the good-old "network did not assign a network address" error. This is with the correct password entered as well, as when a wrong password in entered it doesn't connect to the network at all like normal.

Anyone got any idea why I can only connect when I have no password?
Im not too happy about using an insecure network....

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.