General discussion

Network Controller

Computer Specs:
Manufacturer: Sony
Model: VAIO (Laptop)
Processor: Intel(R) Core(TM)2 Duo CPU 76500 @ 2.10GHz 2.10 GHz
RAM: 4.00 GB
OS: Windows Vista Home Premium

Problem: Where to begin? I tried upgrading from Windows Vista to Windows 7 with the DVD Sony sent me in the mail. Before I could actually begin to install Windows 7, I turned off all system start up items by checking "selective startup" in msconfig. On top of that, an application from Sony started up from the DVD attempting to make sure my computer was ready for the install. It removed "items" from my computer with known issues. After all this, I got 50% into the install only to find that I couldn't finish it because Sony had sent me a faulty disc with corrupt files. I am now awaiting my new disc, but until then I reenabled all the items I had disabled from start up, and have restarted my computer many times since then. My wifi no longer works, the light does not even come on. I can directly connect to the internet via cable, but can no longer use my wifi in classes.

Now everytime I startup my laptop I get a message, "New Hardware Found - Network Controller"... Cool. I'll just install the software and be on my way. Wrong, the computer asks me if I have a CD the Network Controller came with, and im fairly sure I don't. So then I try to find an update online, but can't find one. And on top of that I can't search for a driver update because when I go to "Network Controller -> Properties" the manufacturer is "unknown". However for some reason it keeps taking me to the Intel customer support site to look for an update but never finds one.

Thanks
-Brian

Discussion is locked

Follow
Reply to: Network Controller
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Network Controller
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Re: network controller

The best resource here seems to be Sony customer services. They would know what Vista driver you need and where to get it.

It might be on their site, it might be on their 'driver and utilities' CD/DVD and it might be that you'll have to use their System Recovery DVD to bring the laptop back to factory conditions.
If you object to the last option they might even be able to email it.

Kees

- Collapse -
EDIT:

Also if this helps, under problems and solutions it says:

Intel Wireless WiFi Link Adapter has stopped working properly.

An update tool is available from Intel Corporation that will help solve this problem.

I run the system check on the site and it comes back with
"Product Detected
Current Driver Installed
This device is unknown or unsupported. Please contact the manufacturer for possible updates. More information>>
Wired Networking
Product Detected
Current Driver Installed 10.66.4.3
This device is unknown or unsupported. Please contact the manufacturer for possible updates. More information>> "

My Network Adapter isn't unknown, its:
Marvell Yukon 88E8057 PCI-E Gigabit Ethernet (working properly)

- Collapse -
Oh lord.

Oh god, that didn't work. I went to Sony's sight, found my original drivers and tried to install just the one for Network Controller. It wouldn't install properly, and when I tried to reinstall it--Blue screen of death/MEMORY DUMPING. Computer died for about 10 minutes.

- Collapse -
Device Manager!

Are you installing the driver using Device Manager?

CNET Forums

Forum Info