Samsung forum

General discussion

Network connection OK but Internet@TV won't work on HT-C5500

by swigzine / January 8, 2011 3:04 PM PST

I bought the HT-C5500 Blu-Ray along with a LED Samsung TV last April and everything worked great for a couple of months. Then, after a firmware upgrade, my Internet@TV suddenly stopped working. I can connect to my network wirelessly, and my player has even updated its own firmware. But when I go to set-up Internet@TV, all it does is get stuck on "Downloading..." and never makes any progress!

Samsung customer service has been a nightmare. Anyone resolve an issue like this?

Discussion is locked
You are posting a reply to: Network connection OK but Internet@TV won't work on HT-C5500
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Network connection OK but Internet@TV won't work on HT-C5500
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Network connection OK but Internet@TV won't work on HT-C5200
by LawFish / January 8, 2011 7:42 PM PST

I too have this same issue. However, my Internet@TV worked until I performed my first firmware upgrade. I have since upgraded to a newer firmware version, however the issue remains, Internet@TV is stuck on "Downloading". Does anyone know of a solution for this?

Collapse -
Internet@tv problems..internet connection seems to fail?
by spamba / February 26, 2011 8:33 PM PST

I have the very same issue. As soon as internet@tv is selected..you see the moving "Downloading....." icon and the application freezes. (_Can_ use the [Return] button on my remote successfully, though.)

All possible network tests run very well (all checkmarks!) on my set and I can use PC share manager without any hassle.

In order to fix the problem, tried both soft & hard resetting my HT-C5200...alas..to no avail.

It looks as though this latest firmware update (1014.1 - applied via USB stick) somehow blocks internet traffic both to and from the internet@tv application.. & this goes for both the HT-C5200 - and HT-C5500 series..

Samsung staff - any idea why this will not work?

Cheers..

Collapse -
the solution
by swigzine / February 26, 2011 11:28 PM PST

Well, after endless rounds with Samsung on the phone, I finally demanded that they repair or replace my unit, as it was still under warranty. I had to pay about $70 to ship and insure the unit, even though the work/replacement would be free. They had me send in the box as well as my wifi antenna. The good news is that they sent it back fairly quickly, and it works again...although not very smoothly! Still it's a pain choosing online apps. Samsung customer service was a nightmare the whole way through. No contact or explanation of what was wrong with my unit.

So, the bottom line is that you need to call them (or email) and tell them you have to send it in.

Collapse -
Internet@tv connection problems - HT-C5200 (firmw v. 1014.1)
by spamba / March 5, 2011 3:36 AM PST
In reply to: the solution

Thnx for the feedback swigzine.. but it is quite odd that my set _used_ to work _properly_ (well...agreed..it was slow..but widgets were shown) with internet@tv right before the firmware update to v. 1014.1 (the most recent version). I never used the wireless option. Tried different resets (you can find quite a few - even @ this forum)...to no avail. Still the famous (?) "downloading" icon shows...and no widgets at all.

On various forums in my country there are complaints... and indeed..many customers send in their set in order to have it repaired.
Was just wondering - have any serious hardware changes been applied to your set? Or was the firmware just "downgraded" to a previous version so internet@tv will work...eventually?

Is this a hardware flaw at all? Of purely software? Is a firmware upgrade in the foreseeable future likely?

Again...Samsung staff....please join the discussion...

Collapse -
Internet@tv connection problems - HT-C5200 (firmw v. 1014.1)
by Samsung_HD_Tech Samsung staff / March 7, 2011 4:38 AM PST

spamba,

Internet@TV should be working properly if it was before an update. Why subsequent resets and a different firmware would cause this not to work in a different region is something I'm not able to answer.

The best recommendation I can make would be to contact the Samsung customer service center in your region for further inquiries. I have no information on upcoming firmware updates, for any region, but they may be able to assist further.

--HDTech

Collapse -
did you ever resolve the issue?
by whats_wrong / January 8, 2012 3:10 AM PST

<span class="subject">did you ever resolve the issue?

Collapse -
did you ever resolve the issue?
by whats_wrong / January 8, 2012 3:09 AM PST

did you ever resolve the issue?

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?