Computer Help forum

General discussion

Network Adapter won't connect to LAN or Internet

by saqabb / January 25, 2009 4:18 AM PST

Hi, This is a rather odd problem and I have exhausted all possible issues I could come up with. Up until today I have had no problems connecting to my network - today when I started up my laptop both my wireless adapter and NIC were unable to connect to a network. They both seem to be working fine as I can 'see' wireless connections and when I connect a ethernet cable to my laptop my Local Area Network goes from 'network cable unplugged' to enabled. However neither is able to complete the connection to my network. Other computers seem to be able to connect perfectly fine. Here's the kicker - when I load up a virtual PC I am able to connect to the internet through this.

Here are some things I have tried:
1. Updating drivers
2. Repairing Winsock
3. Changing Auto-Negotiation Settings

Thanks for the help!

Discussion is locked
You are posting a reply to: Network Adapter won't connect to LAN or Internet
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Network Adapter won't connect to LAN or Internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
A few issues I see.
by R. Proffitt Forum moderator / January 25, 2009 4:41 AM PST

No make, model of the laptop so we can't discuss the machine.

All I can offer is the old reset. Read

But that could be a miss too since I could find what OS was in use.

-> I'm not asking for such details but could you tell why these were not in your post?

Collapse -
by saqabb / January 25, 2009 5:41 AM PST
In reply to: A few issues I see.

Hi Bob,

I'm sorry if I was a little vague, I own an LG P300 which runs on Windows Vista Home Premium Edition.

My Wireless adaptor: Wireless WiFi Link 4965AGN

NIC: Realtek - RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC

I tried your suggestion of resetting the Internet Protocol but there's been no improvement.

Thanks for the reply.

Collapse -
Now tell us about your firewall and ...
by Edward ODaniel / January 25, 2009 6:39 AM PST
In reply to: Issues

whether recently you have had any malware problems.

have you tried a system restore to a restore point prior to the problem?

Collapse -
No restore points, no malware (99% sure)
by saqabb / January 25, 2009 6:53 AM PST

Hi Edward,

I have not had any recent malware problems - in fact I haven't installed anything recently, I have Kaspersky Antivirus as well. Unfortunately system restore was off up until now (I know, my fault entirely) and I don't have any valid restore points to go back to.

Collapse -
Additional Information
by saqabb / January 25, 2009 7:57 AM PST

Bob, I will gladly add any information you request but I'm at a loss as to what more I can add. I recently got this laptop (within the last 30 days) and I haven't had any real problems with it. I've been able to connect to my network up until now without a problem and I believe I've taken good care of it so far. I do not think it's a hardware problem simply because the internet DOES work on virtual PC (when I run a virtual OS within vista). I have absolutely no idea what the problem could be. I will try and obtain an Ubuntu CD and see where that gets me.

Thanks again.

Collapse -
I've seen this happen
by R. Proffitt Forum moderator / January 25, 2009 8:09 AM PST
In reply to: Additional Information

And it was malware. Another time it was the firewall. I've lost count of the malware and settings issues. Nothing in your post reveals exactly where to look yet.

It could be as simple as you are using a Web Browser and it's settings are amiss and that is how you test for internet access. I've found in those cases, other browsers and email works but the story is still light.

Try another browser.

Collapse -
I've never seen this happen!
by saqabb / January 25, 2009 8:37 AM PST
In reply to: I've seen this happen

Ok, both firefox and internet explorer do not work. I have just run a full system scan using kaspersky and it did not pick up anything - do you recommend any other software to look for malware? Basically, right now I have disconnected my wireless adapter and have connected my ethernet cable to my laptop, in network connections my 'Local Area Network' connection shows that it is Enabled (as opposed to Not Connected when I pull the cable out). HOWEVER, the little icon in the system tray says I am not connected to any networks (which means no internet either - regardless of if I use internet explorer or firefox). Someone suggested I do the following: I tried going into My Network Connections/Local Area Network/Properties and checked the settings of both Internet Protocols (IPv4 and IPv6) and everything is set up to obtain IP addresses automatically.

Collapse -
The other 2 scanners we use in this forum are
by R. Proffitt Forum moderator / January 25, 2009 11:24 AM PST


You know there is something new that popped into my head and it's that good old HOSTS file. I wonder if the DNS has been hijacked.


Collapse -
Scanned using the two softwares you provided
by saqabb / January 25, 2009 1:42 PM PST


I downloaded the free versions of the two software you mentioned. After running them I found the following:

start.hijack - the log information is as follows:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Start_ShowSearch (Hijack.StartMenu) -> Bad: (0) Good: (1) -> Quarantined and deleted successfully.

SUPERANTISPIWARE also found two Adware cookies, both of which were removed.

I'm not entirely sure what you mean by my DNS being hijacked but to be vigilant I researched the term and the aforementioned Hosts file. I looked up the file in my windows folder and noted that it has not been modified since 2006 - long before I got my computer. So can I be safe in saying that this is not the issue? Regardless, if DNS hijacking means that I am being rerouted to harmful websites I do not think this is the case as I am not able to go to any site whatsoever.

Thanks again for the help Bob.

Collapse -
Compare the DNS and IP CONFIG in Windows and VM
by R. Proffitt Forum moderator / January 25, 2009 10:55 PM PST

Use IPCONFIG /ALL to compare what's being used for DNS, netmask, default gateway and the rest to see where the wheels fell off the bus.

The good clues seem to be missing from your posts and maybe its because you don't know to give it your all. There are no paid staff here so you are jacking up the car, fetching the spare tire and doing all the hard work.

As an example I read the web browser doesn't work but no where do you exmplain or share what happens. Also is that the only thing that doesn't work? Email is dead or not?

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.