Samsung forum

General discussion

"Netlfix keys have been hacked" on BD-P2500

by jerry_sizzzler / June 29, 2009 1:42 PM PDT

I just tried to watch a Netflix movie on my Samsung BD-P2500 and received the message "Your BD Player's Netflix keys have been hacked. You cannot watch Netflix movie through your BD Player."

I've seen a couple posts on Amazon and AVSForum that have steps on how to correct this by deactivating the device (on Netflix), resetting the factory settings on the BD-P2500, and then reactivating the device (on Netflix). However, in order to restore the factory default settings the posts say to hold the FF button on the player for 5 seconds. This does not work on my player; nothing happens when I do this.

Is there another way to restore the factory settings? Or another way to manually delete the settings in memory? I appreciate anyone's input on this issue. Thanks.

Discussion is locked
You are posting a reply to: "Netlfix keys have been hacked" on BD-P2500
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: "Netlfix keys have been hacked" on BD-P2500
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
"Netlfix keys have been hacked" on BD-P2500
by Samsung_CE_Tech Samsung staff / June 30, 2009 2:14 AM PDT


Updating the firmware would also effectively reset the settings. You can try doing that along with "unmounting" your BD player from Netflix it self.

- CE_Tech

Collapse -
"Netlfix keys have been hacked" on BD-P2500: resolution
by jerry_sizzzler / June 30, 2009 4:21 AM PDT

Thanks. I ended up doing this late last night once I realized new firmware had been posted to Samsung's site. Here are the steps that I used:

1. Deactivate your BD-P2500 player on your Netflix account.
2. Download the latest firmware update from Samsung?s support site. ( The latest version as of 2009-06-30 was version 2.6, a file called ?
3. Create a firmware update CD or create the firmware update on a USB drive.
4. Install the latest firmware on your BD-P2500 player.
5. Go into Menu | Setup and re-enter the settings you had previously. (The firmware update will have set the player back to the default factory settings.)
6. Go into Menu | Netflix. It will walk you through the standard Netflix streaming setup. At the end of this process you will need to reactivate your player on the Netflix website.

This resolved the issue and allowed me to view Netflix streaming content on my player. It?s worth mentioning that I do not believe that the firmware update itself actually fixed the bug about ?Netflix keys have been hacked.? For me the firmware update simply allowed me to restore the default factory settings (i.e., clear the on-board memory) because the method of holding down the FF key for 5 seconds didn?t work on my player.

? The reason I had to go through the #2, #3, and #4 steps instead of just Menu | Setup | System Settings | System Update is that there was another bug with my player. When I tried doing Menu | Setup | System Settings | System Update it failed saying "Please maintain ?No Disc? state for network update" even though I did not have a disc in the tray. If you do not encounter this error then you can obviously avoid the manual firmware update and just use System Update.
? If you are unfamiliar with how to burn an ISO file to a CD then step #3 can be a little tricky. Lifehacker has a good post on how to do this for Mac users.

Collapse -
"Netlfix keys have been hacked" on BD-P2500: resolution
by Samsung_CE_Tech Samsung staff / June 30, 2009 4:26 AM PDT


Thanks for the guide and I'm happy that this issue was resolved.

- CE_Tech

Collapse -
reset process
by clay.flannigan / August 1, 2009 1:29 AM PDT

Since I already had the latest firmware installed, updating it did not reset my player. Neither did holding down the >>| button as suggested in the manual. Instead, I had to do the following:

1. Unplug the power cord for the player from the wall
2. Hold down the power button for a minimum of 20 Seconds
3. Plug back in
4. Turn the player on and with no disc in the player, press and hold the FF button on the front
panel until the player turns off.

This allowed me to re-associate my Netflix account.

Collapse -
It worked - with one minor difference
by palmi4530 / July 18, 2010 1:53 AM PDT
In reply to: reset process

Holding down the fast forward on the BD player was the right step but my BD did not turn off. I saw on the BD monitor a "reset". After that everything worked.

Collapse -
"Netlfix keys have been hacked" on BD-P2500 - Resolution
by tha_goat / September 29, 2009 7:32 AM PDT

Thank for the detailed instructions jerry_sizzzler!

I'm having the same problem, including Blu-Ray DVD's won't play...

I went through all these steps several times. I also, de-activated and activated my player with Netflix a few times too. I also tried unhooking the internet, restart the player, and put in Blu-Ray DVD that wasn't working, and then reconnected the internet. Honestly, I'm not sure which step really fixed the issue, but seems to be working now. From other posts, I'm not sure if it will be a permanent fix though.

I actually didn't reinstall the firmware, but will if this happens again.

Just a heads up to all of you having the same issue; When I called 1-800-SAMSUNG, the representative told me there was nothing she could do and that I would just have to wait 2-3 months until the next firmware update. (Really, 2-3 months? I asked her if she thought this was an acceptable answer, and she said "yes". You have to be kidding me!)

I then called Netflix to see if they had any ideas and their tech support was much more helpful. Seems to be an issue they are aware of. I sure hope Samsung get's their acts together in the firmware update world.

Good luck to the rest of you!

Collapse -
RE: "Netlfix keys have been hacked" on BD-P2500: resolution
by jckjr64 / October 25, 2009 11:08 AM PDT


I went to my Netflix account but I don't see a way to remove the device. Under "Manage Netflix ready devices" I don't see any list of my devices and only have the ability to add a device. Where did you deactivate your device? Thanks for the help!!

Collapse -
Deactivating account
by jerry_sizzzler / October 25, 2009 11:21 AM PDT

What I did was click on "Your Account" from the main Netflix page. Then, in the "Billing and Movie Watching Activity" section I clicked on "Your Netflix ready devices and computers" link. (Sounds like this is what you did as well.) When I got to this point there was an entry for "Samsung BD-P2500/2550 Blu-ray Player" and a Deactivate option. That is where I deactivated my account for the Samsung player. If there is no entry here then maybe you don't need to do this step?

Collapse -
Success with restoring Netflix!!!!
by jckjr64 / October 26, 2009 5:27 AM PDT
In reply to: Deactivating account


I ended up in the same spot as you...most current firmware already on the device, etc.. Resetting the player allowed me to reassociate the device. Thank you very much to all that contributed to this forum!

Collapse -
Same problem, but question on Firmware
by Campgems / November 17, 2009 10:29 AM PST

Well, I seemed to have fallen into the same rabit hole. What has me pulling my hair now ist that when I got to Samsung to pull the update, even though my player thinks it has the latest, the one I get is Rel 2.5, not 2.6 as Jerry_Sizzler showed.

Did Samsung pull this relaease? Is there a back door to find it? Does anyone have a copy to share???


Collapse -
Re: Same problem, but question on Firmware
by jerry_sizzzler / November 17, 2009 11:05 AM PST


That is strange. Looks like a glitch on the Samsung site; the 2.5 version appears to be up there twice. Might be worth trying to get Samsung to re-post the v2.6 firmware file. If you don't have any luck with that let me know, I still have the v2.6 zip file. It's about 50MB so you'd need to have an FTP site that I could drop it to.

Collapse -
Back in business
by Campgems / November 18, 2009 4:52 AM PST

Jerry, thanks for the offer. I finally got it running this morning.

I did a reset, and the Blu-Ray came back to life

Netflix was still getting the hacked message

I Went through the pull the plug, power off button and that didn't accomplish anything, but didn't hurt either. I down loaded the USB firmware and put it on a flash drive and loaded it, IT was ver 2.5, same as was on the machine, but it did a full load anyway. No help.

I read this thread the fourth time and I saw the reference to Post #5. I tried that, but no mater how long I held the FF button, it wouldn't power off. I finally gave up and when I got the glare off the screen, I saw that it had reset so I went in and checked thing again and now, I'm back in business.

Thank goodnes for this site. I would have ended up shipping it back for "repair"

Does anyone have an idea what has happend that causes this problem?
I've still got to go back and setup my video again. For some reason, my 1080P TV doesn't give a very good picture unless I set the Blu-Ray to 1080I.


Collapse -
Another possible fix
by surfer1954 / November 22, 2009 2:03 AM PST
In reply to: Back in business

Hi All

Another possible fix:

Turn off unit
Turn unit back on and wait till you have no-disk prompt
Hold down fast forward button on unit (3PM) position for 8 seconds
Unit should now reset and you should be able to access Netflix.
This was only method that worked for me...tried all above methods and suggestions from Samsung FAQ's.
Good Luck

Collapse -
Another possible fix
by MB812 / December 19, 2009 5:10 PM PST
In reply to: Another possible fix

This did the trick after all the above had failed. Thanks for the post

Collapse -
this time it worked
by kentesmeier / January 1, 2010 10:49 AM PST
In reply to: Another possible fix

Another possible fix worked for me. Although I had to try the FF button holding twice.
Coincidentally my actual blue ray of gran torino was not working either. I tested my batman disk and all is good. must have had a bad disk from netflix. All is good cause I'm streaming again.


Collapse -
it worked
by yuconn / January 3, 2010 8:05 AM PST
In reply to: Another possible fix

the first trick didn't work but this one did. thanks

Collapse -
Worked like a charm
by jtgarcia2002 / May 14, 2010 1:46 PM PDT
In reply to: Another possible fix

The 8 second fast forward >> button worked like a charm. Thanks a lot.

Collapse -
It's not working.
by mommycrone / January 23, 2010 5:21 AM PST

I have downloaded the firmware to disc and the player won't read it. It sits there and then opens. I have tried resetting with no disc and I get the opposite of what you got. It tells me 'no disc'. It won't do netflix instant because it says it's been hacked, but, it also won't play anything. We've only been using it for less than 6 months. I find it hard to believe both of these problems are not connected. Can you help me?

Collapse -
It's not working.
by Samsung_HD_Tech Samsung staff / January 24, 2010 5:10 PM PST
In reply to: It's not working.


The firmware may not be updating if the file was burned to the disc. The file is an .ISO file, which when double clicked, should launch the installer. If the disc isn't playing, you might try the thumbdrive method of updating.

As for the "hacked" problem, that would most likely not be related.

To fix this, hold down the FF>> button until the unit turns off, and then reboot the unit. If that doesn't fix the issue, you may want to re-activate the device through your online Netflix account, or by calling Netflix at 866-716-0414.


Collapse -
My experience on this issue and solution
by ajsacnet / January 10, 2010 1:46 AM PST

Here is my experience on this issue:

Received this dreaded Netflix keys hacked message yesterday and also was having issues running Blu-Ray titles from last week.

Here is my theory on what causes the issue: The firmware gets confused after inserting "Ghosts of Girlfriends Past" BD title rented from Netflix. Once this DVD is inserted in the player - it does not play, moreover after this I am no longer able to play other BD titles previously playable plus have the netflix issue.

Solution that worked for me: Unplugging the DVD player for 10 mins, then hitting the FF/Next button until DVD resets and then finally re-registering the player on netflix.

Why I think the "Ghosts Of Girlfriends past" is the issue - after I reset the player and got everything working, I put that BD title back in - same results - it did not play and started getting the same symptoms again. So had to go thru the reset process again to get everything working again.

Calling SAMSUNG support was kind of disappointing - I would have hoped the 1st level support person would be well familiar with the above message and quickly direct me to the solution. Instead the support person said something like "Hey if your system has been hacked - there is nothing SAMSUNG can do - it's your problem". Wow ! After more persistence - got useless suggestions like - try cleaning your laser etc. Very disappointing. The only piece of useful information I got was to leave the unit unplugged for 10 minutes (as opposed to 20 secs etc). Not sure if it is needed, but that's what I did and worked.

Also as per the support person the Firmware update was expected next week (I called on Jan 09, 2010).

Thanks to posts on this forum I was able to get the player back in working condition.

Collapse -
Troubleshooting link received from SAMSUNG support
by ajsacnet / January 11, 2010 4:59 AM PST

Hi All - just to followup my previous post. I emailed SAMSUNG with the summary of the issue and got much more useful information - the links they sent dealt with the issues I was having. Here they are:

Netflix streaming issue:

Unable to play DVDs

(although I can't see how I can raise a support ticket from the above link on unplayable DVDs)


Collapse -
netflix hacking message
by bvi1998 / March 7, 2010 3:03 AM PST

I had trouble with a blue ray disk from Netflix last night, and that seemed to hose the streaming.

To repair, I did the following:

- deactivated the device from Netflix

- downloaded the firmware (same version as I already had) from

- followed the directions here:

- THEN I was finally able to reset the player with the power on/hold down the fast forward key.

- I activated the player on Netflix.

No fun on a Sunday afternoon Sad

Collapse -
netflix keys have been hacked
by samsickofit / January 8, 2011 9:59 AM PST

Another machine produced w/o being completely built. Get it out there and we'll fix it later. F*** the public. Anyhow, when all else fails after the unplugging, blah, blah, turn it on, press FF and if that fails, turn it off, turn it on, hit FF again and if it doesn't reset open the DVD tray and close it. Press the FF button and the Netflix code will come up on screen. Hoo hoo-send up a rocket!! Lucky me-I have a Samsung Time-Warner cable box too. Just Shoot Me!

Collapse -
by R. Proffitt Forum moderator / January 8, 2011 10:22 AM PST
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.