Samsung forum

Resolved Question

Netflix stopped working on blu ray player

by NCJason / November 8, 2012 1:30 PM PST

I have a BD-E5300 blu ray player. I have been using Netflix on it for several months with no problems. Suddenly when I try to connect to Netflix I get the red box with the logo and the moving progress bar but it never connects. The other online apps work correctly. Any suggestions?

NCJason has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: Netflix stopped working on blu ray player
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Netflix stopped working on blu ray player
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by NCJason

Collapse -
Re: Netflix stopped working on blu ray player
by Samsung_HD_Tech Samsung staff / November 8, 2012 11:57 PM PST

Hi NCJason,

Usually when this happens, it ends up being an ISP or Netflix issue, but let's try some things. Suggestions to try:

- Power off the player and unplug it for one minute
- Power on the player and set the timezone

If that doesn't work, try this: Menu > Settings > Network > Wired Network Settings. Change the DNS Server to or

If that doesn't work, open up: Smart Hub > Tools > Settings > About Smart Hub > Details. Then for Netflix ESN, let me know if there are some sequence of letters or numbers or rather phrase. Don't post the sequence of letters and numbers as that's info you may not want posted on the Internet. Just let me know if they're a sequence of letters and numbers of a phrase.

HD Tech

Collapse -
No change yet
by NCJason / November 9, 2012 2:40 AM PST

I powered off and unplugged the unit and verified the time zone with no change.
I tried both DNS Server settings with no change. Other devices on the network access Netflix with no issues.
I do not see an option to access Smart Hub settings on my BD-E5300.


Collapse -
Re: NCJason
by Samsung_HD_Tech Samsung staff / November 9, 2012 3:51 AM PST
In reply to: No change yet
Collapse -
Software reset completed
by NCJason / November 10, 2012 7:09 PM PST
In reply to: Re: NCJason

I did the software reset as per the video instructions. The video said the reset would not affect Smart Hub settings. I still can not access Netflix but the other apps work correctly.


Collapse -
I am having the same issue!!!!
by AGaskill / November 11, 2012 4:01 AM PST

Tried deactivated/reactivating netflix account, unplugged modem, unplugged player, checked internet connection...nothing is working! Netflix plays perfectly on my phone so why is it not working on my player!?

Collapse -
by AGaskill / November 11, 2012 6:08 AM PST

I tried hard resetting the blu ray player...nothing.

Collapse -
(NT) Did you try the Samsung Netflix Konami code?
by R. Proffitt Forum moderator / November 11, 2012 7:34 AM PST
In reply to: also...
Collapse -
Where do you do the code?
by NCJason / November 14, 2012 6:22 PM PST

It was my understanding that you had to do the code from inside the Netflix interface. I cannot get past the Samsung page with all the icons unless I go into a different app. When I click on the Netflix app I just get a red page with a moving progress bar, the Netflix app never loads.

Collapse -
2 ideas.
by R. Proffitt Forum moderator / November 14, 2012 11:11 PM PST

1. Remove the netflix app and reinstall.
2. Call Samsung for support to do item 1 and the Konami.

Collapse -
Re: One last idea
by Samsung_HD_Tech Samsung staff / November 15, 2012 2:05 AM PST
In reply to: 2 ideas.
Collapse -
I've had to do that too.
by R. Proffitt Forum moderator / November 15, 2012 2:34 AM PST
In reply to: Re: One last idea

It's far done on my list of things as I find many folk have a devil of a time connecting up their WiFi at times.


Collapse -
Hard Reset
by NCJason / November 15, 2012 3:16 AM PST
In reply to: Re: One last idea

The hard reset let me reenter my Netflix login information. From what I can tell from some brief testing and power cycling of the unit, I think my issue is gone.

Thank you very much for all of the suggestions!

Collapse -
Quick fix.
by Adlee73 / July 19, 2013 11:55 AM PDT

All I did was go into settings at the main menu & update my software. Wrote down my Netflix code just in case and re-entered it at Worked fine.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.