Question

Netflix app not loading on Samsung Smart TV

I was able to watch Netflix on my Samsung Smart TV until about a few days ago.

Now, when selecting the Netflix app from SmartHub, my screen goes blank and nothing ever happens. It is as if the app is not being loaded.

All other apps in SmartHub work just fine (including HuluPlus, Amazon, Pandora, etc.).

And I can use Netflix on my iPhone so I know it is not the wireless network.

Discussion is locked

Answer
Follow
Reply to: Netflix app not loading on Samsung Smart TV
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Netflix app not loading on Samsung Smart TV
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
(NT) Ui-200
- Collapse -
Clarification Request
Netflix app stopped working on Apple tv

Same identical problem on new LG TV. Was watching Netflix one day and the next day , I click on the icon and it disappears. So can’t delete the app and reload it.

I can watch Netflix on my iPad. Need help.

- Collapse -
Answer
A fix not listed here

I have tried every issue listed on these forums, called Netflix, called Samsung 3 times. Finally on the 3rd time a technical advisor from Samsung had me do a reset on the Hub by clicking the blue D button and entering the default password which was 0,0,0,0. I was unable to connect to Netflix. He then had me change the DNS to 4,2,2,1. This step got me connected.

- Collapse -
still complete BS from Samsung

I have called 4 times in the last 5 weeks.....hours on hold, hours convincing a level one to send me to a level 2 (level ones will just put you through the agony that eveyone above suffered)...get to a level two and they will admit itis a software glitch that their software people are working on "top priority"....whether these guys are chimps or liars I dont know...I do know this, until Samsung's most recent upgrade (mid Feb?) all was well...now I have had no netflix for well over a month and these chuckle heads cant fix it (I'd love to find out how the DNS fix above worked but havent got 2 hours to sit on the phone)

- Collapse -
Why keep it?

If, as you say it's a defect why not move to a return so you can get something that works?
Bob

- Collapse -
(NT) out of warranty
- Collapse -
Perils of jumping into someone else's post?
- Collapse -
Same result

I pretty much went through the same thing step by step. Samsung was not able to tell me why it was happening nor were they able to fix it. I have not been able to use my Samsung Bluray player to watch Netflix (Which is the sole reason I p[purchased it) since the beginning of April. And nothing I have tried has changed a thing. I am no software expert but I can't believe that this still hasn't been fixed nearing two months now. DNS change did nothing for me either...

- Collapse -
It's only going to get worse.

The FCC's new plan means we can't count on this working. Frankly this one may only get fixed after we return products that don't work and the makers hammer the FCC to go back to Net Neutrality.

Some folk will write their PC, Roku or such works but that's just a confuser to some. I see it and don't see much good in keeping products that fail around the place.
Bob

- Collapse -
What page?

Your "fix" is very vague. Please advise what page one is supposed to be on when "clicking the blue D button"; I tried this on the first Smart page and it does nothing. And please describe how to change the DNS to 4,2,2,1.

My problem with Netflix is that (in last months) it takes me to the movies lists and allows me to start load process, but says "movie not available, please try another movie or come back later" or some stupid thing.

I used to be able to work around by going to the smart load apps and "run" netflix from there and it worked, but no more.

And how the hell does one deactivate netflix! This is exacerbating!

- Collapse -
Deactivating Netflix
- Collapse -
the same problem

I'm in Canada, and I'm having the same problems with Samsung. It actually worked really well with Neflix for about 3 years and now.... I have tried everything on this site and nothing is working.

I can't understand why they can't co-operate with eachother, and then... everyone can benefit. Surely there are enough movies and t.v. shows for all competitors to make nice.

What I'm wondering is... is there any product out there that works with Netflix without these issues.

- Collapse -
No.

As I've helped with this over the years the players involved are not co-operating. The fall of Net Neutrality didn't help. ISP DNS servers are often behind and may not catch up for weeks and then your ISP may have some competing service so while they may not actively thwart or impede they may also do nothing about a service interruption.

So simply no.

What you can do is to check if your PC/Apple/other things work which can be clues that it's an issue with Samsung. It's not definitive but it's where I start.
Bob

- Collapse -
Thanks

Thanks so much R.Profitt for responding. I'm really not techie at all but I'm having to research and learn since I'm of the generation where this stuff does not come easily. I have tried everything on this site and nothing is work. The apps offered by Samsung on their t.v. all work, so I am assuming either it's the Samsun g DVD player or Samsung and Netflix are in disagreement.

What I can't understand is how it worked for 3 years... and now...

Thanks again.

- Collapse -
Yes..

This (similar) problem just started with me a month ago. It is currently Dec 17 2015. I generally don't get the error described, but loading is here and there and am never being able to watch NetFlix now. Plays a few seconds and stops for minutes. Over & over. Get the error on occasion. Tried all but getting the hard reset from samsung. Oddly, I have a sony bluray player that also has netflix. It plays fine every time. Netflix is not the only app I have issues with on the samsung. However, using the sony bluray, they all work fine. Just wish I hadn't spent money on a "smart" tv. Next time will be a good tv and use roku or bluray player.

- Collapse -
Too easy to fix 2016 samsung smart 4k ultra

Do not call Netflix.
Do not call Samsung.
Do not do things that can cause static electricity to fry or TV like un plugging it while it's on.

Simply turn your TV off then safely unplug it and leave it unplugged for one minute then plug it back in and turn your TV on it should automatically reset.

As a bonus I'm not getting that little red loading circle is often and my internet service provider stinks so that really is a good bonus.

- Collapse -
worked

this worked for me too. thank you for doing all the leg work and sharing it!!

- Collapse -
"A fix not listed here" worked for me!

Thank you goarmy1971. This was the fix I needed!

"...reset on the Hub by clicking the blue D button and entering the default password which was 0,0,0,0. I was unable to connect to Netflix. He then had me change the DNS to 4,2,2,1. This step got me connected"

Just to clarify, press blue D button on the remote. Scroll to "Reset" and select. Enter 0 0 0 0 and select. From here I tried to log into Netflix but I still got the "network interference" message. I went to Network setup through the TV menu pressed next until I got a message "Unable to connect to the internet..." From here this is when I changed the the DNS manually. (switch from automatic and select manual with remote) enter 4 2 2 1 into the four boxes using the number keys on remote. And just like goarmy1971, this got me connected.

- Collapse -
Answer
For those that add to this post.

The OP (original poster) found their fix. Adding to a solved thread is your choice but you are burying your plea for help. My advice is to make a new thread and use this as source material for what can fix it.

Yes, a lot of folk do not want to call it in. There are alternatives.
Bob

- Collapse -
Lots of fixes all in one thread.

However... One fix doesn't work for all cases. Having multiple fixes in one thread, or variations of a 'fix', allows me to try them one at a time without having to seek them in multiple places or keep track of which ones I've tried already.

So far 0 for 3. But I keep plugging away through other options that people have tried.

- Collapse -
Answer
This WORKS: :D

Okay. It took a few hours but I found a definite fix... If it doesn't work the first time don't lose hope. The first time I switched from the UK to the US it did not work. I listed reasons why I think it didn't work below. But I went back to the UK settings & loaded everything over again but clicked on Netflix & let it open first this time, then went back to US & it opened perfectly. Happy
Also, this works for 2014 models as well.
*All of the edits are from me.
The website I found this hack from originally is at the bottom of this post.


"Here is the fix for everyone with the Samsung Smart TV and Netflix issue. I have had the same issue on my French UE55F7000. Everything worked perfectly fine until suddenly I couldn't open Netflix anymore. The screen would just go black and then back to TV or HDMI.

It seems to be an issue with the latest Netflix update from the US Samsung Smart TV app store.

In order to fix it do this.

1. Go to your Smart Hub and DISABLE "Auto Update Apps". Then Close Smart Hub an go to TV Source.
*(edit: Click menu on your remote>> go to Smart Hub>> Auto Update>> Disable.)

2. Go to Menu -> System -> Setup -> Enter your PIN
*(edit: Menu>> System>> Setup. -I didn't have to enter a PIN.)

3. Go through the Setup Process until you get to the Terms & Conditions Screen.

4. This is for 2013 Models: Hit this Sequence on your remote: Mute, Return, Vol Up, Channel Up, Mute
*(& 2014... maybe other years too)

5. Select a Country that does not support Netflix. ex.) Germany

6. Finish the Setup.

7. Open Smart Hub ... It will uninstall all apps and re-install the German ones (No Netflix).
*(Open it all the way up until you're on the blue screen with the apps that come standard & recommended.)

8. Repeat Steps 2-4.

9. This time select United Kingdom as a Country and finish the Setup.

10. Open Smart Hub and it will install Netflix from the UK Store.
*(This is where I went back a few steps & CLICKED on the Netflix app so it could fully load up before I change it back to US apps... It didn't work when I didn't click the app.)

11. Repeat steps 2-4 again.

12. Now you can select USA and finish the setup once again.

13. When you open the Smart Hub now all the UK Apps will be removed and replaced with the US ones. However Netflix will be untouched and you will still have the UK App but access to US content.
*(Like I said... This didn't work when the Netflix app remained "untouched.">> I took that the wrong way the first time I read it. I guess he meant that the UK Netflix app hasn't been updated like the US Netflix app has.)

14.Make sure that Auto App Update is disable and DON'T update Netflix or you have to go through that whole process again.

15. Enjoy.

It seems like Netflix rolled out the update only for the US App store and the UK App is still untouched. As long as you are running on the older version you will be fine."


*******Anyway. I just got my TV today & my Netflix app didn't work at all when I tried to use it for the first time. I was so upset because Netflix was one of the main reasons I wanted a Smart TV.
Have fun & I hope this works for you all as well.*******


http://support.unblock-us.com/customer/portal/questions...

- Collapse -
Zipcode Problems

Hi - I just bought a new TV and have encountered the problem that everyone is talking about. I got through the setup and entered in Germany but it asked me for my zip code and I'm not sure what to do. I'd like to try and see if the fix you listed will work for me but when I put in a German zip code I found online it still did not work. Thoughts or suggestions? Thanks!!

- Collapse -
Always call those it.

Samsung Germany will have to confirm it's supported or not. Unblockus is not supported in case you were wondering. That is, I don't want you to go around thinking this should work.
Bob

- Collapse -
(NT) Typo. I meant "call those in."
- Collapse -
Sorry: I forgot to add that...

This happened to me as well.
You actually don't have to add a zip code to complete setup.
When you get to the screen where you add zip codes for Germany (or any other country besides USA) there is a button on the right of where you enter the zip code. I forgot what the button says... But it's literally right next to where you enter the zip code & has something to do with choosing from any available cable providers...
-Once you press that button, a list of all available providers will pop up. Click any option & it will work. (There was only one for Germany & there are a few options for the UK.)

If you need anymore help let me know.
No problem!!

- Collapse -
Also...

Germany (& the UK too) will not have to confirm if it's supported or not. It's crazy how you can set your TV to any country you want without having to confirm anything or actually having the cable provider they have listed.
I had fun playing w. a few apps that aren't available in the US when I downloaded the apps from the UK.

I know this works because I used this method last night.

- Collapse -
Fix for Netflix issue

I had the same issue with Netflix on a Samsung 65' curved. I went into smart hub and accessed the first option Samsung apps. As soon as I went in, I got a message that apps needed to update. Netflix was one of them. Now Netflix works.

Changing the country probably works since it erases all of the apps and then does the update of the Netflix app.

- Collapse -
Netflix Not working on dec. 2015 TV

Having the same problem on a brand new TV bought in December - watched Netflix for 4 weeks and all of a sudden it doesn't work tonight. Same Dx as other posts - click on the app and it's a blank "black screen"? What to do - nothing seems to work that I've seen on these threads?

- Collapse -
my solution

In the end the solution for my disconnect between Netflix and Samsung was a Samsung issue of needing to upgrade my DVD player.
Samsung sent me the link, I downloaded the zip file, changed the zip file to a regular file and loaded it onto a memory stick which I then inserted into the dvd player... presto.... a solution to the problem

I'm not a techie person but was able to follow the instructions that Samsung included with the download.

Hope this helps someone.

- Collapse -
Thank you!!!!!

After about 15 calls to Samsung, and going through all the approaches described above, getting forwarded to managers, and manager's managers (and then getting disconnected...twice), I finally found this site. Went through this process with my 2014 model. Works great. Why doesn't Samsung tell you this?

Just want to note that when you get to the terms and policies, you have to uncheck the "I agree" box. To do so, you have to scroll through the 3 specific terms and uncheck. Then you do the Mute, Return, Vol +, Ch+, Mute sequence. Also, as noted already, you can select any Provider to get through the setup.

Thanks again!

CNET Forums

Forum Info