Resolved Question

.NET Framework 4 won't install

For some reason I cannot install the .net framework that is needed for a lot of software. I have tried installing it from the Microsoft website directly and through other software installation programs. I just did another attempted install from the Microsoft website and here is my full report:

http://pastebin.com/5Sm04J05


Please help!

Discussion is locked
Jakeleber has chosen the best answer to their question. View answer
Follow
Reply to: .NET Framework 4 won't install
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: .NET Framework 4 won't install
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Install message error

If you look in the installation report you can see that there is this error:

[9/22/2012, 18:58:51] Returning IDOK. INSTALLMESSAGE_ERROR [Service 'Windows Presentation Foundation Font Cache 4.0.0.0' (WPFFontCache_v0400) could not be installed. Verify that you have sufficient privileges to install system services.]


I don't know how I would go about fixing that.

Best Answer

- Collapse -
Possible the most obvious solution -.-

I use Comodo antivirus software which includes a type of 'defense' system for my registry. I just disabled that feature and it installed perfectly fine on the first try.......

Thanks for the help and sorry for the waste of time Silly

- Collapse -
Answer
So did you try the old .NET cleaner? Link follows.
- Collapse -
Used cleaner based on suggestions from other threads

I did use the cleaner in that link based on a suggestion in this thread where the guy seemed to be having the same issue as me.

I also tried installing Windows Installer 4.5 and using it to repair files because of this thread

Forgot to mention that I am running XP Pro SP3

Not sure if this helps but I do have a folder in my "WINDOWS\Microsoft.NET\Framework" directory named "v4.0.30319" which has files in it.

- Collapse -
See above

I see that the issue of PROTECTION or Antivirus suites was noted. So with that noted, why not delete that folder after you used the cleanup tool?
Bob

CNET Forums