Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Video Games & Consoles forum

Resolved Question

Need help troubleshooting. PS4 won't acess PSN

by Jyode008 / September 22, 2016 12:05 PM PDT

I brought my ps4 from the states to Aghanistan to use while I am here. I am using an ISP (ifone neda) that provides service to my area. It uses public access points with a Web page login with you're own user name and password. When I try to sign into psn I get an error code NW-31247-7 (A DNS server cannot be used, The DNS server did not respond within the time limit) however this was not always the case, when I first got here I had no problems but within the last 30 days it's been doing this. I was playing Destiny yesterday with absolutely no issues and it was working great. But i wanted to see if it was accutally fixed so i disconnected the Internet and tried to reconnect and I got the error code CE-33987-0 (cannot connect to psn within the time limit) so I tried logging out and logging back in and now I'm back to the first error code (I should have just stayed connected when it worked). The Internet on the ps4 works fine just trying to reach psn is my problem. I tried contacting playstation but they have yet to get back to me. And I cannot use their online chat because it is telling me I have to go through my region for support which doesn't offer chat, I can't switch regions (tried) because my PSN accout is a US account. If anyone has a fix please let me know. Here is some information that may be useful...

Using a cat5 cable connected to the router/ also tried wifi with same issue
Using a public access point
4mbs dl/2mbs ul
Nat type 2
Not using a proxy or vpn
Can easily log into psn on pc/phone/ps4 web browser
Stream netflix on ps4 fine (Internet works fine just no psn)
Tried reseting the router and unplugging it
Called my ISP they said it every thing was good on their end told me to check with psn
Thought it might be my service but other people are using PSN fine from here.
Reinstalled latest firmware 4.0
Tried different mtu settings
Can use ps4 remote play with my pc just fine
Tried multiple access points

Jyode008 has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: Need help troubleshooting. PS4 won't acess PSN
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Need help troubleshooting. PS4 won't acess PSN
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by Jyode008

Collapse -
Access points with login systems can be trouble.
by R. Proffitt Forum moderator / September 22, 2016 12:20 PM PDT

The ISP should know what's up with the PS4 but since I'm not them my workaround would be to look at a PC as an router. There's Virtual Router, Connectify and more to pull this off.

You say you have a router but that router should be handling the login so I'm not getting what the setup is here.

Collapse -
After a little more reading.
by R. Proffitt Forum moderator / September 22, 2016 12:22 PM PDT

Since your internet works (netflix and such) this is starting to sound like Sony is GeoBlocking. You'll have to VPN home.

Collapse -
Seems like blocking to me too
by Jyode008 / September 22, 2016 12:54 PM PDT

I tried to run a VPN through my PC but come to find out my PC won't support a Hosted network. Next option would be a DNS or IP proxy setup in my PS4 connection settings but I'm not very familiar in doing so. I guess my question would be if I am being blocked could it still allow a connection every once in awhile? because some times I can connect. Its probably a 90% won't connect / 10% will

Collapse -
As I don't run the Sony network
by R. Proffitt Forum moderator / September 22, 2016 1:11 PM PDT

(everyone breaths a sigh of relief) I can't guess why it's hit and miss. I can't guess what setup to use under this condition but your setup is quite the mystery. If it takes a login, here the router does that. But that's not what you wrote.

Collapse -
router
by Jyode008 / September 22, 2016 9:16 PM PDT

I am not sure if the router takes the login. Once I connect, my web browser pops up and takes me to a login screen. With the PS4 I have to set up the network connection then manually open the web browser, type in the address and login that way before it allows a internet connection for that device.

Collapse -
That's a new one.
by R. Proffitt Forum moderator / September 23, 2016 9:19 AM PDT
In reply to: router

I'm going to think this router is not a bog standard router. That could be why it's wonky.

If the router is ISP supplied that could be it. Anyhow if this was mine I'd be looking at using my PC as the intermediary or a VPN since Sony is known to GeoLock access.

Post was last edited on September 26, 2016 8:02 AM PDT

Collapse -
thankyou
by deejaymisty1 / September 26, 2016 1:11 AM PDT
In reply to: That's a new one.

Nice thankyou

Collapse -
Issue resolved
by Jyode008 / September 28, 2016 4:34 AM PDT
In reply to: thankyou

I'm not sure what the fix was. But it started working a couple days ago and hasn't stopped. I did email my ISP to have them verify that the ports on the router needed for Psn were open and they said they were. But a day later it "magically" began working

Collapse -
To me this magic tells me it wasn't your gear.
by R. Proffitt Forum moderator / September 28, 2016 7:42 AM PDT
In reply to: Issue resolved

Anyhow, calling it in was your best move.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!