Linux forum

General discussion

Need help - Interesting problem

by Kalam1ty-22293802990939816613452473116340 / March 5, 2009 6:59 AM PST

So here's what happened:
I decided I wanted to use linux and promptly hopped through several distributions dual-booted on my computer. Everything was going great, EasyBCD really was easy, and then I tried OpenSUSE. The installer was very confusing, and after much research, I finished the install. However, I mixed up 'boot' with 'root' and the next thing I knew, the GRUB was showing up first when I booted my computer. While it works, it's definitely not what I was going for. Since then, I have gotten the Vista BCD back, but I can't dual-boot Linux from it anymore. Here's what I have tried so far to fix the problem:

-System restore (the restore worked, but it didn't fix the problem)
-Automatic Boot Fix with install cd (it said there was no problem and thus did not fix it)
-bootrec.exe (failed to recognize my Vista install and would not rewrite all of my boot files)
-Easy BCD restore utilities (say they work, but don't fix the problem)

Any suggestions? I'm on a Lenovo T61, Vista Ultimate, 32 bit, Intel processor, previously had no trouble with this. Let me know if you need more information, I have no clue what else I can do.

Discussion is locked
You are posting a reply to: Need help - Interesting problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Need help - Interesting problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
What grub does.
by white-bread / March 5, 2009 3:40 PM PST

Grub is the boot loader and must be there for your machine to load any OS. It is not malfunctioning. Without it you have a useless piece of metal and plastic.
Look.
Redo the installation of SuSE, use grub.
When the screen comes up, hit the space bar and use the arrows to choose the system that loads. then you hit enter.
You can choose windows as your default boot target. This is where you should create a virtual machine- virtualbox, qemu, don't use any microsoft projects- on which to practice using a linux distribution.

If you need help, let me know and I'll give you some install tips.

Collapse -
Yes, however...
by Kalam1ty-22293802990939816613452473116340 / March 6, 2009 1:29 AM PST
In reply to: What grub does.

I guess my original post was confusing. I'm very well aware of exactly what a GRUB is and how it works. The problem is that the windows system for managing a boot is more misterious to me. I'm worried that the fact that I can no longer return to the setup I had before (use EasyBCD to create an entry that references the Linux Grub in the boot sector of the 40GB partition I made on my harddrive) because it has trouble finding the Grub no matter which distro I install (tried Ubuntu, Mint, Fedora, Suse).

I have been dual-booting using the Linux grub as the main boot manager for both Linux and Vista, but I'm very worried about what changes were made to my windows boot sector that are making it malfunction and why none of the standard recovery utilities seem to be fixing the problem.

This may be related, but is equally mysterious: the last time I had used the Grub as the main boot manager was on a fresh install of Fedora 10. Before installing, I used EasyBCD to remove the linux entry and rebooted to make sure it was no longer there. After the install was done. However, after the install was finished and I rebooted and elected to boot into my windows partition, a the BCD I had before with a windows AND Linux entry popped up. At this point I had not yet recreated the Linux entry. Is it possible that I have 2 BCD's on different sectors of my harddrive? I can't think of an explanation for as to why this would happen, or what I would do to fix it.

This may be easier if you summarize what you think happened to my computer, because this is hard for me to communicate as I haven't encountered anything like this before and have never had occasion to describe it. I may not be making things as clear as I think I am and would like to make sure that what you're reading and what I think I'm writing match up. Thank you for responding so quickly, though.

Collapse -
grub2
by white-bread / March 6, 2009 2:47 AM PST
In reply to: Yes, however...

The boot sector of the disc is independent of any OS.

Okay.

You're going to have to find the bcdedit file and edit it to include the paths to the linux install.

Howto do it, I don't know. Look for easy bcd or something.

Collapse -
I maybe all wet...if I am, let me know.
by ahtoi / March 6, 2009 3:59 AM PST
In reply to: Yes, however...

Let's regroup, what are you trying to do and what's not happening?

Collapse -
Solved! - Will put solution in separate post.

So I finally solved the problem. Here's what was happening:

My hard drive has 3 partitions: a service partition, a vista partition, and a newly created linux partition. While looking at distros, I decided to install OpenSuse to try, but accidentally installed the GRUB to /root instead of /boot. This created an interesting situation:

-the Suse grub now appeared before the windows BCD (previously I was using EasyBCD to dual-boot independently of the Grub to avoid potential problems)
-the BCD that I had originally set up appeared when I chose to boot windows from the Suse grub
-the BCD still worked as intended (the windows entry booted windows and the linux entry went to the grub)

while it worked fine, I didn't like the idea of being dependent on the grub to boot windows as it was my main OS, and I decided I didn't like OpenSuse anyway, so I installed Fedora 10 (this time correctly installing the grub to the first sector of the linux partition) and something interesting happened again: I couldn't boot windows.

I had expected this, so I inserted the Vista install dvd to restore the boot sector and was again able to boot into windows. However, when I tried to create an entry in the BCD for Fedora, it appeared on boot, but could not point correctly to the grub (whether I used EasyBCD or the more complicated bcdedit.exe method).

Interestingly enough, when I re-installed Fedora with the grub again as the main bootloader, I had arrived at the same situation as with OpenSuse with one glaring exception: The bcd displayed when selecting windows was the same one I had with Suse before, and not the new one that I had just created.

Then I tried to completely reinstall the windows boot sector from the install dvd using bootrec.exe, but it couldn't detect my windows install, even though it let me select it on a previous screen.

Anyway, to make a long story just slightly shorter, I spent a few days running through forums trying to fix the problem and found a solution (which I will not pretend to understand, at this point I was just blindly following posted instructions). So for anyone else like me who had this problem, the post below might help.

Collapse -
(NT) Main thing; it's working..nice going.
by ahtoi / March 9, 2009 12:27 PM PDT
Collapse -
Solution

-Insert your Vista install dvd, select "Repair My Computer," and open the command line.
-Type "bootrec /fixmbr"
-Restart and boot into windows
-Open the start menu and right click on "Computer." Select "manage"
-Do one of the following
-goto your drive manager, right-click on your Vista partition and select "Mark drive as active" (This is the part no one posted to do. I'm not in windows right now so the phrasing might not be exact)
-mark your Vista partition as active using the command line (I'm not a huge fan of the command line so I don't know how to do this, but a search should bring a plethora of instructions).
-Reboot into the Vista install dvd and go back to the command line
-Type "(cd drive letter):"
-Type "cd boot"
-Type "bootsect /nt60 (vista drive letter):"
-Type "bootrec /FixBoot"
-Type "bootrec /FixMbr"


Anyone who can follow this, feel free to post alternatives and/or corrections.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!