In Windows XP go to Start/Control Panel/Mouse/Pointer Options tab, uncheck the box for the "Snap To" feature. Click apply, OK. That may solve the problem.
I bought a mouse once that did this. Turned out to be built-in feature of the mouse that I couldn't disable.
Best of Luck