General discussion

My wireless connection keeps dropping out..help!!

ive been having problems with my wireless internet connection latley...it doesnt matter what im doing online, but my connection keeps dropping every few minutes or so. Ive got a linksys WRT54G router and im running windows XP. Basically what happens is i'll be browsing web pages or playing a game online and my connection will die for a few seconds and then either come right back, or come back when i right click the network icon next to the clock and re-connect to my network. The router is in a different room than my laptop usually is, but i dont think thats the problem because even when the connection drops out it still listed as 'good' or 'very good'. Im desparate for help, ive spent hours searching google but none of the fixes ive found seem to do much help.

Discussion is locked

Follow
Reply to: My wireless connection keeps dropping out..help!!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: My wireless connection keeps dropping out..help!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Had same problem. Think I fixed it (touchwood)

I had this problem same router too. Maybe just a coincidence. It was very odd for me though. Every few minutes the laptop dropped the connection to the network, but still had internet access(!)
I am assuming you have some sort of security on your wireless network (WEP WPA etc). If not, then the following advice is of no use. If you have, then read on.
Windows XP is poor at saving WEP keys. Basically if:

(a)you get it wrong when you set the connection up, then go into the connections properties to change the key

or

(b)decide to enable security after the initial setup, then try and add the Key into the properties for the connection,
Windows does not save the new key. I have had similar issues with Outlook express accounts not saving properties when modified in the past too. If you have WEP enabled on your network, the best thing I found was to:

1)Open NETWORK CONNECTIONS from CONTROL PANEL
2)Right click on the connection and select PROPERTIES.
3)There should be a tab for WIRELESS NETWORKS.
4)Find your network by name near the bottom and click REMOVE.
5)Click ADD then you will need to enter your network information manually in the window that pops up. You will need to uncheck the box that says "My key is provided automatically"

SSID is the network name.
NETWORK KEY - This is the important one. get it wrong and click OK and when you go back in to modify it Windows screws up and saves it wrong. You can enter network keys in ASCII (typed letters) or the HEX that the router converts the key into. 5 ASCII/10 Hex is for 64 bit, 13 ASCII / 26 HEX is for 128 bit. Your key must be one of these 2 lengths.

All being well, when you click ok your connection will connect in the blink of an eye, and remain stable.
Mine has been stable for 1.5 hrs since I did this, with no drops at all, and it seems to have cured the problem. Hope it helps you too. I know what a pain in the *** it is trying to find an answer on the net!! Hope this is the one that fixes your problem.

- Collapse -
Having same problem... are you still?

I'd be interested in any follow-up on this issue. My connection is also dropping every few hours. (I also have a Linksys WRT54G, and also run XP.) Although my ISP allows only one computer to access the account, I set up the wireless router LAN and both computers are able to get on. But every few hours, the connection is dropped. If I try to repair the connection, I cannot get a new IP address issued. If I power cycle the modem and turn everything back on, it is up and running again.

I have just cloned the MAC address of the original PC assigned to the modem. I have yet to see if it works. But wouldn't a problem with my ISP mean that I wouldn't be able to connect at all?

So, if you have any follow up to your own problems, I'd be interested to hear.

Thanks!

- Collapse -
WiFi Connection Dropping

Have you tried unchecking the box 'Enable IEEE 802.1x authentication'. This can be found by:

1) Access Network Connections through the control panel.
2) Right click the connection for your wireless adaptor and select properties.
3)Click the authetication tab in the new window.
4)The box you want is the top checkbox. Uncheck it.

I read that once someone did this it cured the issue. They managed to get this out of Linksys themselves. This box needs to be unchecked, as it only worked with it checked on the older routers with older firmware. The routers that ship now have a firmware version that requires this box to be unchecked to work. The guy didn't say why this was, but try it. I'm sure I probaby changed this setting when I was frantically trying to cure the problem, and it is likely to be the setting that cured it.

GOOD LUCK!!

- Collapse -
Thanks

You fix of removing and installing the adapter did the trick

- Collapse -
idk

i don't think its just a coincidence i have the same router and its drops to.

- Collapse -
Re: My wireless connection keeps dropping out..help!!
- Collapse -
Similar problem fixed

Hi, I had a very similar problem. My laptop had a 802.11b card in it and my router was broadcasting 802.11b and g. When I changed the router to 802.11b "ONLY" it worked a treat. Works fine now. I had been pulling my hair out for years.

- Collapse -
SAME PROBLEM

I have a NETGEAR G router and every time I use my wireless home phone my internet drops off.
Does anybody know what's going on with it ???

- Collapse -
Collision

Your home phone, microwave, and wireless router work on the same wave so if they are too close together they can interrupt each other. I was having the same problem and every time the phone rang or I used the microwave it would knock me off the internet. You can either:

a.) Move your router farther way from these devices to avoid interference or
b.) Spend a couple more bucks and get a dual band router so when one band is interfered by the microwave or the home phone the router will switch to another band to avoid interference.

- Collapse -
Common Problem

This will happen to alot of wireless device.

CNET Forums

Forum Info