Windows Vista forum

General discussion

my mouse doesn't work!

by cinimin6 / July 7, 2007 1:51 AM PDT

hey! i just loaded windows vista last night. i've tried three different mouses, rebooting in the middle of plugging them all in and everything! but it doesn't seem to matter what i try to do, i can't get my mouse to leave the middle of my screen. it's always there...and doesn't move. did i accidentally install something i shouldn't have when i formatted?

can anyone offer any help?

Discussion is locked
You are posting a reply to: my mouse doesn't work!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: my mouse doesn't work!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
No most mice (if not all)
by mark04276 / July 7, 2007 8:57 AM PDT
In reply to: my mouse doesn't work!

the basic movements work fine without any software added. Are you using usb mice or PS/2 mice? If PS/2 make sure it is plugged in the mouse slot and not the keyboard. If usb, try a different slot if you have one available.

Collapse -
I have this mouse (A4Tech)
by R. Proffitt Forum moderator / July 8, 2007 3:38 AM PDT

That is a lump of plastic until the drivers kick in. While it's working ok it's fine but I wouldn't suggest this model to anyone because the drivers must be installed to get the mouse to work and...

You need a mouse to easily install the drivers. (think about that!)

It's the X-710 by A4Tech and I bet their other models are just as annoying.

Bob

Collapse -
It may not be the mouse at all,
by retired / July 8, 2007 3:50 AM PDT
In reply to: my mouse doesn't work!

Could be the computer is simply freezing because Vista is over burdening the system. Or a bad driver, or a another bad piece of hardware.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!