Question

My Laptop Wont Start But POWER LED Indicator is On

BEFORE I START WITH THE PROBLEM STATEMENT :
------------------------------------------------------------------------------------------------MODEL : TOSHIBA SATELLITE C640D
SPECS: AMD ATHLON II
2GB RAM
HITACHI HDD 320GB
WINDOWS 7 OS
(NEWLY REPLACED CMOS, SCREEN)
___________________________________________________
I have a problem with myToshiba Satellite c640d. It wont turn on, but the Power LED Indicator is on! When I press the power switch, it starts for only a second or less before turning off again(when it starts to turn off,the LED also turns of as well, before lighting up again). Ive tried so many solutions, including the discharging method, replacing and testing several RAMS and checking the HDD's status, even replacing the CMOS battery. Everything is perfectly fine. I checked the processor's core, everything seems to be fine. The thermal paste is still in working state (still not dried up). I got it working again with luck a few times though, and its random, but it only turns on for 5 seconds(it made to the boot screen) and after that it shows a system error, something about a problem with CMOS. But the thing is, the battery is still new. And I bought 3 batteries!(and even tested with each and every one of them) If my laptop made it that far(sometimes i got through til the log on screen and actually logged in my user before it starts powering off suddenly!), then I'd say its not the motherboard, not the processor, not the CMOS(maybe it is but still its new!!) not the HDD and not the RAM, and most certainly not the screen.

What should I do?What did I missed? Please help me.

Discussion is locked
Follow
Reply to: My Laptop Wont Start But POWER LED Indicator is On
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: My Laptop Wont Start But POWER LED Indicator is On
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Re: laptop won't start

This reaally looks like some hardware issue on an old laptop. If you can't find it yourself, I wouldn't spend more money for it but buy a new laptop.

Kees

- Collapse -
Answer
Is this that 2011 or older model?

I'd move on. This sounds like a bad motherboard and the cost of that repair should be about the same as a new laptop.

CNET Forums