Since the link to your site goes to your homepage, not to the pictures of the screen, I've removed the link.

The plan to execute:
1. Check if you installed the right video driver for Windows 7, and if the resolution is set to the native setting of the screen.
If that doesn't work.
2. Go back to factory conditions (Windows 8.1). If you hate Windows 8, go forward to Windows 10, not backwards to Windows 7.

And just a detail: in English it's a web browser, not a web wanderer.