Sort of like; "My car doesn't work.. Please fix it..".. More information is needed.. Make and model? Operating system? Which service pack for that operating system? Laptop or desktop? What type of internet connection? Which antivirus program is installed? Is it updated and kept current? Do you use Windows Updates and keep the computer current? Have you recently installed any new drivers, especially those that come from Windows Updates? Tried running system restore yet? If the steps above don't help, give it a try.. The more information you provide us, the better suggestions we can provide.

__________________________________
Since the video players you've mentioned all use Flash Player, have you tried uninstalling the old and installing the newest version? (For Chrome, you'll need to install the latest version of Chrome as the Flash installers below won't help that particular browser) If not, try the steps below to do so.

First, uninstall Flash by using the Flash Uninstaller at the link below..
http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_14157

After that's done, then download the appropriate offline, manual Flash player installers from the link below. If running two browsers, you may need both installers.

Flash Player for IE 32& 64 bit:
http://download.macromedia.com/pub/flashplayer/current/support/install_flash_player_ax.exe

Flash Player for Non-IE browser (Opera, Firefox etc):
http://download.macromedia.com/pub/flashplayer/current/support/install_flash_player.exe


Next, disable Hardware Acceleration withing Flash like this:

So first, check if you can see the Flash animation (banner) without the system crashing at:
http://www.adobe.com/software/flash/about/

Don't worry, it's not a video, it shouldn't crash -- if it does, this won't fix your issue. If it works without crashing, right-click on the Flash animation (banner) and uncheck "Enable hardware acceleration" from the Settings panel. You should now be able to view the YouTube videos without crashing the computer.

And on Windows 7 computers, some folks are finding relief for your issue in Internet Explorer, by opening the Control Panel-Internet Options-Advanced tab.. Once there, place a CHECK mark in the box next to "Use software rendering instead of GPU rendering", then click on "apply", then OK.


Hope this helps and let us know more.

Grif