General discussion

My Files Don't go to the recycle bin!

Hi!
When I delete a file it won't go to the recycle bin, and Windows ask me if I want to delete the file instead of asking me if I want to send the file to the recycle bin!
I have the "Don't send the files to the 'recycle bin'..." option deactivated.
Can someone help me with this?
Thanks

Discussion is locked

Follow
Reply to: My Files Don't go to the recycle bin!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: My Files Don't go to the recycle bin!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Re: My Files Don't go to the recycle bin!

Open the following page and click the R letter. Scroll down until Recycle Bin and besides other things you'll find " Replace/Repair the Recycle Bin (Line 64)".

Good Luck,

Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
Just a thought

When you deactivated the option "Do not move files to the Recycle Bin", did you click Apply, then OK?

Also, what Maximum size of the Recycle Bin do you have?

IF it is set too low, (mine is 5% of my hard disk), any deletions may bypass the bin.

Mark

- Collapse -
That can also happen

if the recycle bin is full.

- Collapse -
Re:Just a thought

First of all, I haven't deactivated that option, it was already deactivated and the maximum size of my recycle bin is 10% of my hard drive

- Collapse -
Re:Re: My Files Don't go to the recycle bin!

Thanks, but it didn't worked out =(
Any other suggestion?

- Collapse -
Re: Re:Re: My Files Don't go to the recycle bin!

Check out the NoRecycleFiles in the right pane under the following registry path:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\

If NoRecycleFiles is in the right pane and its value is 1, change it to 0.

For more details, read:


Do Not Move Deleted Files to the Recycle Bin.


Notes

For launching click Start, Run type regedit and press Enter.

Before doing some registry changes, create a Restore Point.


Good Luck,

Cetin

Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
Re:Re: Re:Re: My Files Don't go to the recycle bin!

Thanks again, but... It didn't work again . ='(

- Collapse -
Go to the recycle bin ...

OK, let?s check again the registry entry. The correct path it?s:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Note

HKCU is HKEY_CURRENT_USER

So, tell me did you find the NoRecycleFiles entry in the right pane ? or - not ?

If you found it, did you change its value to 0 ? Also, you need to Log Off and Log on.


I?d suggest to talk more about what you did instead of giving a one line reply.

Good Luck,
Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
Re:Go to the recycle bin ...

Ok. So, I went to that path but that entry wasn't there.
I don't know if should have done this, but I've created a new DWORD value with that name and with value to 0 (I've made a registry backup first). Then I restarted my computer, deleted a file but it still doesn't work! =(
That was all I've did.

- Collapse -
Re:Go to the recycle bin ...

OK, that was a good description. If it wasn?t there, creating a new one with 0 as value shouldn?t have any effect,as you?ve already seen.

At this point temporarily install another keyboard and test the delete function again.

Good Luck,
Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
Re:Go to the recycle bin ...

Just one doubt: what difference does another keyboard makes? I ask this, because when I do right click>delete on a file it won't go to the recycle bin too.

If that's what I really have to do, i think it's take a while because I don't know were will I get another keybord without buying one =P.

P.S.: I noticed that I can't write the other '{' symbol.This problem is with the keyboard right?

- Collapse -
The test is necessary ...

Well, your trials (right click, Delete and inability to use { key) confirms the new testing direction I pointed out for your problem.

The keyboard replacement test it's absolutely necessary. It was good if you borrowed one for a 5 minutes test. From the virtual world, I can help you by showing what to do (but I can't give you a keyboard).

On a collateral note, check your PC for viruses and Spyware. For the latter, open the Try Microsoft Windows AntiSpyware (Beta) thread where you'll find the link. Download, Run and post a report in that thread what pests it founded.


Good Luck,

Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot


Good Luck,

Cetin

Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

- Collapse -
THANK YOU VERY VERY MUCH!!!!!!!!!

I just made this personal acount only to say you this: THANK YOU VERY MUCH!!! you are my hero, I finally could fix my recycle bin trouble. Thanks again.

Sorry about my bad english.

- Collapse -
The 4GB File Bug in the Recycle Bin?

I'm unsure why I haven't found this documented, but even with the recycle bin set to use more percent of the drive, even on a 300GB drive, when I've deleted a 10GB video capture file, an error box appears that such won't fit in the bin but must be deleted.

It's a bug.

Bob

- Collapse -
Try this.

? Empty the Recycle Bin. Reboot and try to delete a file.(create a sample file ! )

? Toggle ON/OFF the option to put deleted files to the recycle bin, rebooting and test each time. This may 'shock' the System back to its senses.
(if the option is ON, set it at OFF. If it is OFF, set it ON )

AS always, make sure your machine is free of viruses and other parasites.

- Collapse -
(NT) (NT) Meant for Devil_shark
- Collapse -
THANKS

Hey! Thank you all by your help (specially to Cetin that gave me all those tips), but I've solved the problem (someone answered my question @ the Microsoft newsgroups =P)! Here's what i've done:

Start - run: cmd
In the command window: cd c:\ and Enter
in C:\ write: rd /s recycler and Enter,
reeboot your PC.

- Collapse -
A happy end story. The correct removal procedure and more ?

Actually, you were lucky with that fix. In my posted subthread all those causes could arise your shown bad symptom (including a defective keyboard).

Although AFAIK, the damaged Recycle Bin should have other symptoms, I'd take your word that it includes your problem too Wink

Now, I'd correct the guy's procedure from another Newsgroup (next time confess it before). The correct instructions are as below:

Click Start, Run type cmd and press Enter. Type the following commands and press Enter after each:

c:\
cd c:\
attrib -s -h recycler
rd /s recycler


Close cmd and Restart PC.

Note

If your C: drive it's FAT32 you should type recycled instead of recycler (for NTFS). This is important and it's an oversight I saw on many fix sites.

Side Effect

If you use the above procedure, and you have multiple partitions, files in the Recycle Bin are shown as real files for the corresponding partition and as shortcuts for the another partition(s).


You are welcome and Good Luck,


Cetin

Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot

CNET Forums

Forum Info