Storage forum

Question

My external hard drive won't mount? Help! :(

Hi everyone! This is my first post here.

I have a 500GB Seagate GoFlex Pro that's Windows formatted. It contains the only backup of the files on my HP laptop which I no longer have. I got a MacBook Pro and I was planning to use the external hard drive with my Mac, so I decided to copy all of my files from the external hard drive onto my MacBook so I could reformat the external hard drive for Mac.

While I was copying my files from the external hard drive, I'm not exactly sure how, the USB connecting the external hard drive to the MacBook was disconnected. I plugged it back in and it showed this message: "The disk you inserted is not readable by this computer." It gave me the option to initialize, eject, or ignore. I've tried ejecting and ignoring it. I opened up Disk Utility and I see that the drive for my external hard drive shows up in the left sidebar but the disk under the drive name does not show up. I've also tried plugging it in to a Windows computer but it is undetectable.

I went through forums and, based on what I read, I got a copy of DiskWarrior. I read through the User Manual, though, and it said that the external hard drive has to be formatted for the Mac, so I don't think I can use it for my external hard drive.

Any suggestions on how I can get my hard drive to mount? I'm desperate here. I really need to recover the files from the external hard drive.

Thanks. Sad

Discussion is locked
You are posting a reply to: My external hard drive won't mount? Help! :(
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: My external hard drive won't mount? Help! :(
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Look at the welcome or lost and found at top of this forum.

In reply to: My external hard drive won't mount? Help! :(

Other titles are noted and other ideas given. If all else fails you move to the recovery houses.
Bob

Collapse -
Answer
Take out of the box or data recovery

In reply to: My external hard drive won't mount? Help! :(

Hi,

Try to take it out of the box and connect it as desktop/laptop hard drive that is inside. If it won't work, don't try to do anything crazy, try some data recovery companies

Collapse -
Answer
There's hope...

In reply to: My external hard drive won't mount? Help! :(

There's a utility that can find lost partitions get it at findandmount.com

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.