Windows Legacy OS forum

General discussion

My disk cleanup isn't working?

by ibs2005 / June 4, 2005 3:22 PM PDT

I have a Dell laptop about 1 year old and when I try to run a Disk Cleanup the message box comes up and doesn't do any thing.
I need help.

Discussion is locked
You are posting a reply to: My disk cleanup isn't working?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: My disk cleanup isn't working?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Disk cleanup help
by Papa Echo / June 4, 2005 7:40 PM PDT

Which message box came up ? Did the program 'calculate" how much space can be saved ? Did you check the boxes then OK ?.

Collapse -
by ibs2005 / June 5, 2005 3:25 AM PDT
In reply to: Disk cleanup help

Thank you for replying to my message.
The "disk cleanup" message box.
It starts calculating how much space can be able to be free on (C) and it takes forever scanning the compresse file.I even waited for an hour and it didn't finish scanning the compress file.

Collapse -
Try ...
by Papa Echo / June 5, 2005 8:48 AM PDT

? Run chkdsk /r
? Then defrag
? Only then Disk Cleanup

It may take time, but may be a solution.

Collapse -
Here's an easy solution
by Tufenuf / June 5, 2005 9:13 AM PDT

If you're uncomfortable editing the registry go to the link below and scroll down to 48 and you'll see the "Disk Cleanup - Compress Old Files Freezes" Fix in the right column, download it and run it which should correct your problem.
Just click on the words "Disk Cleanup-Compress Old Files Freezes" not the underscored word "Undo".
"To use the Regedits: Save the REG File to your hard disk. Double click it and answer yes to the import prompt.


Collapse -
by sunilnair / June 17, 2005 9:05 PM PDT

Thanks a lot Tufenuf - it worked for me Happy

Collapse -
easy solution
by at_hen_a / February 14, 2007 7:46 AM PST

Hi, I tried your suggestion and it worked. Thanks a lot.

Collapse -
by brinnanrose / May 7, 2007 11:20 AM PDT

I have windows 2000, what should I do? I tried to get in to the registry and it asks me a question and that's it and once I answer y or n it just closes no matter which I choose and my computer is constantly low on space because I can't run my disk cleanup. Do you have any advice for me?

Collapse -
by NewtNut / December 7, 2007 8:39 PM PST

worked great

Collapse -
Thank You!
by kstanis / July 13, 2008 5:36 AM PDT

Tufenuf: I sure thank you a whole lot. I've been hassling with this for a long time, Disk Cleanup freezing on the first scanning box. I found and tried some fixes I found on google, that I really didn't understand (creating a regedit file, etc.) and also, tried "free" scans that would then make you buy a product to do the fixes.

I just used the link you posted and your instructions...and voila! For the first time in ages I was able to do a Disk Cleanup. (I have 2000, not XP, by the way.) CNET is cool -- now I feel like, why try anyplace else first? And you people who freely help other people are awesome. Thanks so much.


Collapse -
disk clean-up not working
by trusmibatik / July 15, 2010 9:47 PM PDT

hi Tufenuf, followed your instructions and clicked www.kellys-korner.
now a dumb question,"how do i save the REG File to my hard disk?"
i saved it in my Documents, but cannot do anything with it there. your advice appreciated.

Collapse -
Re: saved in My Documents
by Kees Bakker / July 15, 2010 9:59 PM PDT

Now find the file in My Documents (using My Computer or Windows Explorer) and doubleclick it. And answer yes to the import prompt.

Or is your system so corrupted that you can't run Windows Explorer anymore, or your mouse doesn't work to doubleclick? That would be serious.


Collapse -
disk clean-up not working
by trusmibatik / July 15, 2010 10:59 PM PDT

hi kees, went to my documents and dble clicked "deletecompressedoldfiles.reg" and got box with"Open File-Security Warning" do you want to run this software? I clicked RUN and got box with"Registry Editor"-do you want to add etc.etc to the registry and I clicked YES.
got another box again Registry Editor stating-Information in C:\Documents and Settings etc etc is succesfully entered into Registry.
where do i go from here ,i am 75 years of age so any assistance will be greatly appreciated

Collapse -
That's great.
by Kees Bakker / July 16, 2010 3:24 AM PDT

So you did what tufenuf thought would solve your problem. Did it?


Collapse -
import prompt
by trusmibatik / July 16, 2010 8:25 PM PDT
In reply to: That's great.

hi kees, thank you for your concern. no, i have not solved the problem as yet.
you say to click YES to import prompt, but i cannot find "import prompt"
please see my actions in post 13

thanks again, kees

Collapse -
Re: import prompt
by Kees Bakker / July 16, 2010 8:39 PM PDT
In reply to: import prompt

The program that processes the .reg-file when you doubleclick asks something like "Do you want to add the contents of ... to your registry?" That's what's meant with the import prompt. Answer Yes or No (or OK or Cancel, whatever is on the buttons it shows).

You're nearly there. Now let's hope it IS the solution to your problems.


Collapse -
problem solved
by trusmibatik / July 16, 2010 9:30 PM PDT
In reply to: Re: import prompt

thank you very much, kees, for your help and patience. i think it is working now.
i am very grateful for your advice.

dank je wel!

Collapse -
Worked like a charm!
by jannmirch99 / November 12, 2012 10:16 AM PST

This has been driving me crazy. I followed your instructions and viola!

Collapse -
console tools!
by liquinoid / November 14, 2012 4:14 AM PST
In reply to: Disk cleanup help
Collapse -
Similar problem
by rgfitz / June 5, 2005 3:43 AM PDT
Collapse -
You can also look at:
by rgfitz / June 5, 2005 3:48 AM PDT
In reply to: Similar problem
Collapse -
Disk Cleanup Help
by ibs2005 / June 6, 2005 3:13 PM PDT
In reply to: Similar problem

Thank you, it did work.

Collapse -
by rgfitz / June 6, 2005 12:02 PM PDT

You might also find Cleanmgr in System 32 and right click to Properties.

Then click Advanced and uncheck "Compress contents to save disk Space"

Collapse -
Disk cleanup not working
by olderthandirt101 / June 10, 2005 3:19 PM PDT

Riht click each disc and/or partition and runChkdisk by hitting tools,Check Now and OK for reboot and be patient,especially if you chose more than one option.

Collapse -
That happened to me today - there were too many compressed
by DarCLew2 / February 14, 2007 10:51 AM PST

files. Later, when you are doing okay, when you go to disk cleanup, click on compressed files. Under the box is Options. It is set to saving 50 days of compressed files. Mine is set at 1 day. If you pass 1 you be in the 500's , just back it up to 1. It shows as zero compressed files most of the time. Darrell L.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?