Windows 10 forum

General discussion

My computer is suffering from insomnia

Hello,

The problem I am facing is a rather annoying one, as probably the majority of the computer-related nuisances bringing people on forums like this. I have decided to create a new thread after having perused a dozen or more discussions on similar topics, that is, related to the sleep feature, without finding the right answer. In a nutshell this is what is happening: About a month ago, my computer has started to wake from sleep without any obvious reason. In the event viewer these awakenings can be followed under the Power-troubleshooter event in the Windows logs. Invariably the source is marked as unknown. I tried to get more information using the lastwake command prompt, but to no avail at all, the answer it gives equals to unknown. The time of these awakenings is very different, it is not a fixed hour or minute of the day. For example: 04:08:25, 12:37:06, 04:18:35, 02:27:25, 12:05:40, 02:03:44, 12:43:54, 12:13:32 etc. Usually a couple of hours pass between the events, but there are days, when it wakes almost hourly. I will try and upload a screen capture of the Event viewer so as to show you the event sequence. I have already gone through all the possible settings that could be responsible of this problem, but it is still there. As a makeshift solution, I have adjusted two minutes for the computer to go to sleep if no mouse or keyboard event. I had in addition to recur to a small program that lets me quickly enable or disable the sleep feature with a single click from the tray, similar to Caffeine but better, more flexible (DontSleep). It all works fine now, the annoyance is considerably reduced, but still I haven’t got the slightest idea as to the wake source. Could it be a virus that wakes the computer in my absence in order to break into the system and get my bank details or something of the sort? Any hint would be appreciated.

Post a reply
Discussion is locked
You are posting a reply to: My computer is suffering from insomnia
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: My computer is suffering from insomnia
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
go into BIOS

In reply to: My computer is suffering from insomnia

and turn off WOL or Wake On Lan.

Collapse -
I continue to use that to review settings.

In reply to: Re: insomnia

Collapse -
Thank you for your replies.

In reply to: My computer is suffering from insomnia

Hello,

Thank you for your replies. Unfortunately I still haven’t found the solution of the problem. I had a look at the links you provide, but nothing seems to apply to my case. What I have tried so far:

1) I have disabled Wake timers here: Control panel > System and Security > Power Options > Edit Plan Settings > Change advances power settings > Sleep > Allow wake timers: Disabled

2) I have disabled WOL (wake on LAN), here: Device manager > Network adapters > Atheros netwok adapter > Properties > Advanced > Wake on magic packet: Disabled

3) I have ruled out all network related wake sources by switching off my router overnight: Even with the router off, my computer was still waking up.

As to the BIOS, I didn’t even take the trouble, because I reckon, if the source is not on a network, it couldn’t provide a solution.

I am looking forward to further suggestions.

Collapse -
Also, if you haven't done so,

In reply to: Thank you for your replies.

disable the power option to allow Windows to turn off any network device when not needed. I could suspect that this interferes with the ability to turn it back on or fully wake up. This also goes for Windows normal shutdown process which, if I understand correctly, is more of a hybrid version of it's hibernate feature. Personally, I've found that there are fewer startup problems when Windows "fast startup" feature is turned off completely and a full refresh done when restarted. It takes a little bit longer to be ready in the morning so just have yourself an extra donut while waiting.

Collapse -
Re: insomnia

In reply to: My computer is suffering from insomnia

I had the same. My PC woke up from hibernate spontaneously, even while in the power settings wake timers were disallowed for planned tasks. Month ago, this morning again.

I traced it, month ago already, somewhere else in event viewer to task sih under Windows>Windows update with does some scheduled automatic updates of Windows update software and Windows 10 apps. It was set to run daily at 04:00 and occasionally I found my PC active when I came down at 08:00 or so. So I changed it to weekly start at 09:00 to be able to keep an eye on it (which I usually forgot).
This morning however the PC was on again at 08:15. I now UNchecked the "Wake computer from sleep to execute this task" in task planner and kept the "Do it as soon as possible when it has not done at a scheduled time" option checked.

Moreover, it seems that task planner doesn't know about daylight saving time. The task is set to run at 09:00, but it runs at 08:00. That's kind of a bug in Windows 10, I think.
And I should say that the "don't" wake settings in Control panel>Power options should prevent the scheduled task to run when the PC is hibernated. Clearly it didn't. That's another bug. I think.

I think I've seen even seen tasks that were planned every 20 hours. Those could give rise to seemingly random wake ups.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.