do you get the same problem when you run explorer without MSN explorer - if so it sounds like MSN explorer is the culprit.
However, make sure you haven't got a double entry in the blocked security list (ie one to block and one to allow) - also make sure the name of the site is correct - try without the "http://" just with "www....".
Also make sure that "www.SmartMoneySelect.com" is the only name of the site being used to download the info and no other variation as well.
check to see if your default security settings haven't been changed (tools\internet options\security) or that none of the "advanced" setting have been changed (tools\internet options\advanced).