This is most likely caused by not having enough system resources to support the program opening multiple databases or large quantities of information. Thus, let us know what your system specs are, especially how much RAM you have, what OS you are running, and what version of Excel this is. In addition, let us know what AV and spyware protection you have, because malware is also a possibility.

The first step would be to close any unneeded programs. First look at the system task bar (by the clock) and right-click and close any programs you don't need (but make sure you leave antivirus and firewall running). Then press ''ctrl + alt + del'' and close anything else that doesn't need to be running. To prevent these programs from launching automatically in the future, go to the start menu, look in the ''startup'' folder, and right-click and delete anything that doesn't have to start when you turn on your computer. Finally, go start->run and type in ''msconfig'' (without the parentheses), and look under the start-up tab for any programs that don't need to launch when you start your computer. Just make sure you know what you are unchecking before you uncheck it, as many of the programs listed are required for your computer to run properly.

Once you provide us with more information we'll be able to advise you where to go from here.

Hope this helps,
John