Audio & Video Software forum


MP3Rocket: "Unable to access jarfile lib\MP3Rocket.jar"

by jwolfeld / April 28, 2013 7:56 AM PDT

MP3Rocket, both upgrade and fresh install, getting error message "Unable to access jarfile lib\MP3Rocket.jar" on startup.

This worked as recently as yesterday, before I accepted the upgrade. Now even when I uninstall and reinstall the old version (which I happened to have kept), I still have this problem. This isn't a problem with Windows Java settings. The jar file itself is simply not there where it's supposed to be.

Have tried turning off all virus scanners and intrusion detectors, as well as starting the installer As Administrator, no change. Anybody have any ideas?

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: MP3Rocket: "Unable to access jarfile lib\MP3Rocket.jar"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: MP3Rocket: "Unable to access jarfile lib\MP3Rocket.jar"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
where can i get this file at and fix this
by rhyanmclaughlin28 / August 1, 2014 3:35 AM PDT

MP3Rocket: "Unable to access jarfile lib\MP3Rocket.jar"

All Answers

Collapse -
No success
by jwolfeld / May 2, 2013 10:19 AM PDT
In reply to: Did you see this

Thanks. Tried it, but it didn't work for me. I also found that MP3Rocket leaves a large number of files under C:\Users\(my-user-name)\AppData\Roaming\MP3Rocket, even after uninstall (I'm on a Windows 7 system). I tried deleting them as well before reinstalling to a new directory, but no success.

I noticed that not only is the MP3Rocket.jar file itself missing, but in that lib directory there are a lot of xxx.pack.gz files, and no jar files at all. I'm thinking that MP3Rocket is just one of many files that should be there which aren't, because the installer was somehow unable to unzip and unpack all of these files.

Does that ring any bells with anybody?

I recall that I installed 7zip on my computer not too long ago. I uninstalled it and tried MP3Rocket again, but there was again no success.

Collapse -
Did you update Java to the latest version?
by Ed Mead Forum moderator / May 2, 2013 11:47 AM PDT
In reply to: No success
Collapse -
(NT) The fix i found
by shotbuzz / July 16, 2016 12:33 AM PDT
Collapse -
The fix i found
by shotbuzz / July 16, 2016 12:39 AM PDT

OK so what i did was on windows 7 go to control panel, programs and features. Remove mp3rocket and java. Go to C:Program files remove any folder called mp3rocket that is left. Click on the start and search mp3rocket right click then click on open file location and then remove all files found. keep searching till none are found. On your keyboard press and hold the windows logo key and R. Will open run command type in "temp" without the "" and click enter. Remove all files it allows you to. Open run command a 2nd time and type in "%temp%" without the "" and again remove all files it will let you. some are running in background "no problem" leave those.... Reinstall the program and it will reinstall java. BOOM worked 100% for me.

Collapse -
FIXED - MP3Rocket: "Unable to access jarfile lib\MP3Rocket.j
by Snulty / September 16, 2016 8:31 AM PDT

I am running Microsoft Windows 10 Version 1607 OS Build 14393.187 and was unable to successfully convert any youtube videos to MP3 files. Because I use the Edge to do my browsing, I never run Java updates. So I ran the latest Java update which was Version 8 update 101, my machine rebooted without my consent after the install. After the reboot I tried to launch MP3 Rocket and then I got the "Unable to access jarfile lib\MP3Rocket.jar."

I uninstalled java completely. Then I uninstalled MP3Rocket completely. I rebooted and then ran the MP3Rocket setup again. At the end of the installation, I noticed that the installed bogged down where it had previously moved quickly. I am sure it was installing Java. After the fresh install, MP3Rocket worked and I looked and it had indeed installed Java version 8 update 31. I am guessing they haven't updated their Java in their newest version of the program.

I think if you simply uninstall Java and then run the install of MP3Rocket it should fix your problem.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.