Question

Most apps I own (specially google apps) don't work.

Hi, I own an HTC desire 628. It's working fine until I visited a different country.
It started to show a lot of lag, and most apps started to not work. They will not launch and will not respond. Google apps also do not work, (all of them) YouTube does launch but only loads forever.

Things I've tried:
-Cleared Data and Cache of Google Play Services, Google Playstore, YouTube, Google.
-Restarted my phone
-Turning "Automatic Date and Time" on
-Tried different internet connections in different places.

So help me please
Thanks
-rieth

Discussion is locked

Follow
Reply to: Most apps I own (specially google apps) don't work.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Most apps I own (specially google apps) don't work.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
When all else fails....

Do a system reset/restore and reinstall the applications.

- Collapse -
I have

I have tried reinstalling the apps but I don't think that's the problem here (Thanks for the reply)

- Collapse -
I think there are many issues.

1. When you change countries the Play Store may not offer all apps. Wait till you get back home.
2. Lag after moving afar? Many apps talk to some server and if you were in Canada then went to China the Great Firewall is going to give apps grief.

Again, you wait till you get home to tackle these issues.

- Collapse -
Answer
ost apps I own (specially google apps) don't work.

Try updating the google chrome

CNET Forums

Forum Info