Desktops forum

Question

Monitor loses DVI signal, PC still running

Hi everyone! its my first post here so please enquire about any information that I've left out which could potentially be useful!

Basically, the problem is that my monitor goes black and displays the DVI no signal message on the screen, and it does not recuperate, it's still on and perfectly functioning, but has no signal. It's a brand new benQ monitor and Ive tested this on an older asus monitor which I had used prior to this, the issue happens on both monitors. Secondly, my PC is still running, skype calls and games are still running fine as the audio is still there even without the dvi signal, forcing me to hard shut down my pc. All specs and performance details are in the pictures attached. Could anyone provide me with answers as to whats wrong here and what needs to be done to fix this? it would be a massive help and greatly appreciated. I built this PC in JAN 2013 and it's been reliable ever since, never failing before bar a few viruses. I did a full system restore this week, reinstalled and updated all drivers but the problem seems to still occur, albeit it ran perfectly fine for 3 days, even when I was gaming. The games I commonly play are total war warhammer, on high graphics, shogun 2: total war, high graphics and dota 2 on high graphics. The monitor seems to lose the DVI signal at random times however, even when I'm not gaming, which is a serious problem as I rely on it for my uni coursework, I have alot of engineering software on it that's expensive and cant afford to lose my harddrive data.

https://i.imgsafe.org/0b7ebe5771.png
https://i.imgsafe.org/0b7ede4b63.png

Discussion is locked
You are posting a reply to: Monitor loses DVI signal, PC still running
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Monitor loses DVI signal, PC still running
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Missing a lot of specs. Let's try SPECCY.

In reply to: Monitor loses DVI signal, PC still running

Collapse -
Answer
What other graphic connection on...

In reply to: Monitor loses DVI signal, PC still running

the card? Try other cable on it. It appear it's ok on the monitor side.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

REVIEW

Sublime suburban chariot

High on style and technology, the 2019 Volvo XC90 is an incredibly satisfying everyday crossover.