Question

Monitor flickering when starting up a game

My monitor flickers in different shades of black whenever I start up a game. The colours make it look like the display is turning on and off. I can alt-tab/ctrl-alt-del to kill the game but the problem persists until I restart. After I restart my computer, the games work fine and I can play for hours.

I have reinstalled my graphics drivers, then my operating system, switched monitors with a friend and ruled out overheating(since I could play for hours after a restart).

A friend of mine suggested that the only thing constant in my tests was my habit of putting my computer to sleep at night but I dont think its causing the issue since a lot of people do that right? But indeed after a night's sleep the games act up again.

Any help with my issue would be appreciated.

My system:
Intel Core i5 3570 @ 3.5Ghz
MSI Pro Gaming Motherboard (I forgot the model number)
Nvidia GTX 760 from MSI
700W PSU Silverstone
128gb Samsung SSD
750GB Seagate HDD

Games:
Warthunder
Witcher 3
Fallout 4

Discussion is locked
Follow
Reply to: Monitor flickering when starting up a game
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Monitor flickering when starting up a game
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
If it only happens from sleep

And a reboot solves it, then it's some driver issue. Try the latest from your card's maker and if not try other than sleep. Try hibernation.

- Collapse -
Answer
Check your monitor

Make sure you turn off anything saying "automatic contrast" or "automatic brightness".

CNET Forums