Windows Legacy OS forum

General discussion

MMC cannot initialize the snap-in

by bigmarkclark / November 22, 2009 12:13 PM PST

I got an error message for itunes. I needed to restart the itunes service. I go to admin tools and click on services and received the following error:

MMC cannot initialize the snap-in
Name: Services
clsid {58221c66 ea27 11cf adcf 00aa00a80033}

I can access msconfig but cannot restart any system programs from there.

I am running Windows XP Proffesional Version 2002 SP3

I searched Microsofts website but could not find any info for the clsid number. Can anyone help Please?

Discussion is locked
You are posting a reply to: MMC cannot initialize the snap-in
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: MMC cannot initialize the snap-in
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I read this one.
by R. Proffitt Forum moderator / November 22, 2009 11:04 PM PST
http://support.microsoft.com/kb/907265

And came away with the feeling this OS's days are numbered. Try that hot fix and read more about why you get that message. Sadly, since you do control the itunes or such you should continue to see this failure.

However since I run itunes on a XP pro machine one wonders how you provoked this error.
Bob
Collapse -
MMC cannot initialize the snap-in
by bigmarkclark / November 23, 2009 2:59 AM PST
In reply to: I read this one.

thanks for the reply Bob. I downloaded the file and it said there is a newer version already running on my computer and it would not revert to an older version. Any other suggestions?

Collapse -
Think over how you got XP into this position.
by R. Proffitt Forum moderator / November 23, 2009 3:03 AM PST

While I could uninstall itunes and do that again your machine is truly in a state I rarely see. I won't have a ready fix save the M.A.D. one.

Sorry but more clues are needed to see a better solution.
Bob

Collapse -
MMC cannot initialize the snap-in
by pccare_himanshu / November 24, 2009 4:00 PM PST

To resolve this problem, you must replace the missing Atl.dll file. To restore the Computer Management MMC to full functionality, follow these steps:
Click Start, and then click Run, type the following command, and then click OK:
Copy C:\Windows\winsxs\x86_microsoft.tools.visualcplusplus.runtime-libraries_6595b64144ccf1df_6.0.0.0_x-ww_ff9986d7\atl.dll %windir%\system32\

Collapse -
What to do next
by bigmarkclark / November 25, 2009 2:18 AM PST

I did as you suggested. It asked me if I would like to open the file then it wanted to browse the internet to find a program to open it. What do I do after I click on ok? Thanks for your help.

Collapse -
Another KB article to try.
by R. Proffitt Forum moderator / November 24, 2009 8:44 PM PST
Collapse -
Did not work
by bigmarkclark / November 25, 2009 2:22 AM PST

When I put the string into the run box and clicked on ok it said windows cannot copy. I tried it without the copy at the front and that did not work either. Any other suggestions.

Collapse -
MSFT has some dozen articles on this.
by R. Proffitt Forum moderator / November 25, 2009 2:59 AM PST
In reply to: Did not work
Collapse -
How it happened
by bigmarkclark / November 25, 2009 3:31 AM PST

I have not been aboe to figure out how or when this happened. I am leaning toward a possible hkey ot shared .dll file got deleted when I uninstalled a program but cannot be for sure.

Collapse -
Sorry.
by R. Proffitt Forum moderator / November 25, 2009 4:18 AM PST
In reply to: How it happened

The search I gave you needs to add the word XP to it.

This is a strange error. I can only guess that some program did a bad thing. It reminds me of those machines hit with registry and other cleaners. Usually an OS reload is the cure.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?