Question

missing DLL file (win xp - sp3)

Hi
Just tried to instal a program on my win xp service pack 3 machine and I recive the following error message

The proceder entery point _i64tow_s could not be located in the dyunamic link library msvcrt.dll

Question: can I get this file needed to run this program from somewhere and will the file run on my OS

Thanks
Batista230

Discussion is locked
Answer
Follow
Reply to: missing DLL file (win xp - sp3)
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: missing DLL file (win xp - sp3)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
That library

Looks to be for a 64 bit version of Windows which XP SP3 is not.

Even if you had the file, it looks like it won't fly.

- Collapse -
64 bit

yes the clues in the name
point _i64tow_s
at an educated guess it menas 64 bit dose it not?

- Collapse -
dose as in medication?

Why not? I looked up that function with a google and it appears to be used in 64 bit apps which do not have a patch or workaround to run directly on XP SP3.

Just a side note: Yes there was a 64 bit XP but it's SP ended with SP2 so I can 100% write you have a 32 bit OS.

-> As Grif noted, you could reveal more to see if the app has a 32 bit XP compat version. Some members are good at such hunts but alas such detail is missing.

- Collapse -
Had to dig around to find Natron.
http://www.ocsmag.com/2016/01/03/the-video-editing-challenge-part-ii-natron/

The maker's site at http://natron.fr/ and even https://natron.fr/ currently is down so I can't check out if they have a 32 bit version.

XP support was removed in Blender as noted at https://blender.stackexchange.com/questions/64693/install-blender-on-windows-xp BUT they note what version you have to find.

All indications with what you are showing is you are attempting to install a 64 bit app on a 32 bit OS.

No one I know has been able to fix that. No one.
- Collapse -
Now I see. A zombie.
- Collapse -
it supports 32 and 64 bit
- Collapse -
(NT) And Have You Tried Installing the 32Bit Option?
- Collapse -
The thing is

Microsoft DEPRECATED a lot of API functions in XP to harden security. I only have what you supply to work with so what you revealed showed a 64 bit call which is DOA. (dead on arrival)

But that image shows something more and you need to take install failures back to the site/company/group/person that made this installer so they can either fix it or reveal if they removed XP support like Blender did recently.

- Collapse -
Answer
It's Going To Be An Ongoing Problem With Unsupported XP

It might help if you tell us which program you're attempting to install but especially if the program is something new, any installs will be problematic. Also, you didn't type the EXACT error message you've seen so that makes it more difficult for us to help. Your issue isn't that the "msvcrt.dll" is missing but instead, the program being installed can't find a way to access it.

Hope this helps.

Grif

- Collapse -
more info

The CD disk I am trying to install from my "win xp sp3 OS"
The program is called narton (dont know which version though) and its an video editing program

I hope the below screen shot photos helps in identifying the error message. But I think you are right about the dll. file being there and the program not being able to find it, please see the last screen shoot.

Do you think if I moved the file into another folder would do the trick?

https://www.dropbox.com/s/hepp85pa2dr35ae/1.jpg?dl=0

https://www.dropbox.com/s/9k8lnpoazuza88i/2.JPG?dl=0

https://www.dropbox.com/s/x7jwkuwwk2pqer2/3.JPG?dl=0

- Collapse -
Answer
Let's say your goal is to edit video with Natron.

CNET Forums