I suspect the Lenovo "ThinkAdvantage" wireless configuration package is disabling the Windows service with each restart. Sometimes even using msconfig to turn off startup items doesn't work if some service can just turn them back on. You'll need to go to msconfig and just turn off all the Lenovo startup items with the exception of the hard drive shock utility. Then, go into services and find those for the many Lenovo features and set them to manual. Turn on Windows wireless zero and try again. If no go, recheck msconfig to see if some startup object you turned off is back on again. If so, it's back to services to search again for the culprit. Make sure to check the "apply" button with each change. Don't disable Windows services during this process. If this fails, you can just uninstall the ThinkAdvantage wireless config package. It's on the laptop and/or available at the Lenovo download sight if you think you want it back. Good luck.