Mac Hardware forum

General discussion

Mini Problrm

by Fouad Bakht / October 28, 2005 9:54 PM PDT

I own a Mac Mini (1.42GHz, 80GB, 512MB, Combo, No AIrport/Bluetooth). It came pre-installed with OS X Panther and a DVD upgrade kit was included for Mac OS X Tiger. So after some use I decided o upgrade to Tiger. As per instructions i inserted the DVD, double-clicked the installer file which prompted me to click the restart button. The machine restarted fine, but at the time it was suppoed to boot from that DVD, it just ejected it without any reason, apparantly. Followed by a flashing Mac/ Question mark sign on a grey background. This followed by athe regular Apple logo and the machine booted up perfectly into its native OS. I tried a hundred times and the same thing happened. Then I thought it must have beem problem with the DVD like the drive being unsble to read the zero-track etc etc so I tried to factory restore the system with its bundled Mac OS X Panther Install DVD. Upon restart, this DVD was also ejected. Although, if I just force the DVD inside the slot loading combo drive just after it is being ejected, it then works ok but this is not the way it should be. I also tried holding down the C key or the mouse button (as instructed by Apple) by no luck. I checked the drive for any hardware defect but it seems tootherwise work, work and work....perfectly. I also changed the startup disk to DVD drive but no luck. Everytime the drive just throws out the media. Please help. The local apple support has no answer to this.

Discussion is locked
You are posting a reply to: Mini Problrm
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Mini Problrm
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Mini Problem
by mrmacfixit Forum moderator / October 29, 2005 12:26 AM PDT
In reply to: Mini Problrm

The reason the DVD is being pushed out at startup is because the system cannot find a valid System on the DVD.
Take the Apple Hardware Test Disk, that came with your machine, and attempt to boot from it. (follow the instructions)
If the machine boots from that CD, then the drive is working correctly. If it doesn't you may have a faulty DVD for Tiger.
Holding down the "C" should force the machine to LOOK at the Optical drive to see if there is a valid system in there, if there isn't, it will look in other locations, Network, HD, for one. Once it finds one, it will boot from it. Holding down the Mouse Button will EJECT the CD/DVD so that is a pointless exercise anyway. You could try Zapping the PRAM. Turn the machine on and immediately hold down the Apple key + Option + P + R until you hear at least 3 chimes. Then let go. Resetting the PRAM (Parameter RAM) sometimes sorts out a lot of things, including the Startup disk. You may have to reset date and time but that is a small point.
Do NOT try pushing the DVD back into the slot when the machine is pushing it out. You WILL loose. Do NOT try any hardware "repairs", you will loose again, this time it will be the warranty that you loose.
Let us know

P

Collapse -
I Tried But......
by Fouad Bakht / October 29, 2005 4:18 AM PDT
In reply to: Mini Problem

First, I dont have an Apple keyboard so zapping the PRAM that way is a different story. But since you had a very valid point there about this resetting the PRAM, I found the following info :

http://docs.info.apple.com/article.html?artnum=300574

I am going to give it a try. What bugs me is that I tried the same process sometime back for a fresh install and it worked perfectly alright without having to hold down the C key. This time it wont budge.

Collapse -
That might work
by mrmacfixit Forum moderator / October 29, 2005 6:34 AM PDT
In reply to: I Tried But......

The keys on a PC keyboard are basically the same. They just don't have the same symbols on them.
Try a little experimentation and you will find that you can do anything involving keys.
Option = Alt on the PC


Good luck

P

Collapse -
I Think We Have Some Results
by Fouad Bakht / October 30, 2005 10:05 AM PST
In reply to: That might work

Resetting the PMU worked, partially. When I select startup drive from system preferences as my slot load combo drive, the mini does actually boot from the install DVD but if I double click the install icon from the DVD contents folder or icon on desktop, it wont and instead, eject again. Now what? Any logical explanation for this?

Collapse -
I'm confused on one point.
by R. Proffitt Forum moderator / October 30, 2005 8:16 PM PST

This is a NEW system.

Where is your support?

Apple is famous for great support and you are making a case here that it's not.

Bob

Collapse -
I'm not convinced
by mrmacfixit Forum moderator / October 30, 2005 9:35 PM PST

that this problem has been run by Apple. The term, Local Apple Support, does not sound as though the "official" Apple is even aware of it. Just what is "Local Apple Support"?

P

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?