General discussion

MFC42u.dll problems

Hi everyone.

Recently I installed a bad driver. Stupid move on my part. Got rid of it, but it still left a mark. Whenever I tried to open Device Manager, it would give me an error saying that MFC42u.dll could not be found. I did a few System Restores, no luck. Then I looked for and found another copy of this file in my system folders. I copied it to where it needed to go (Windows\System32) and now it gives me another error message.

"The application as unable to start correctly (0xc000007b). Click OK to close the application."

At this point I have no idea of what to do other than nuke and reinstall Windows. I see this possibly becoming a larger problem in the future. Do any of you guys have any ideas? Thanks in advance.

OS: Windows 7 Home Premium 64-bit

Discussion is locked

Follow
Reply to: MFC42u.dll problems
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: MFC42u.dll problems
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Forgot to mention, it isn't a virus.

Scanned with Comodo Internet Security.

- Collapse -
Tried Registering the dll?

Simply placing the file in it's location doesn't let Windows recognize it.. Try this:

Open the "Run" utility from the Search line, then type:

regsvr32 mfc42u.dll

Then click on OK.

Hope this helps.

Grif

- Collapse -
Another error

First of all, thanks for the help.

It's giving me another error message...

"The module "mfc42u.dll may not be compatible with the version of Windows that you're running. Check if the module is compatible with an x86 (32-bit) or x64 (64-bit) version of regsvr32.exe."

I pulled this copy from C:\Windows\SysWOW64. I doubt that this is a 32-bit version of the file, but I could be wrong.

Any other ideas? Thanks again for your help.

- Collapse -
Looks Wrong...

The names for the EXEs are still the same. So regsvr32.exe is the right exe. There is only a difference in the directory:

x64-EXEs are stored in: \Windows\system32
x86-EXEs are stored in: \Windows\syswow64

Hope this helps.

Grif

- Collapse -
Thanks Grif

Thanks for the help Grif.

Now I know that that DLL I had was the wrong one. Today I kept looking for a solution, and found that I should try sfc. I did, but it gave me an error that it found corrupt files and to check the log. It said that the source file in the store (backup) is corrupted.

Here's one of the messages:

"Cannot repair member file [l:20{10}]"mfc42u.dll" of Microsoft-Windows-MFC42x, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing"

One thing I noticed is that it says my processor architecture is AMD64, but it is actually Intel's EM64T. (My processor model is Intel Pentium E5200.) Of course, it could just be Windows code...(I don't really have a clue).

Is there any way to restore this file off of the Windows DVD? Thanks for all your help guys, I really appreciate it.

- Collapse -
A Basic Repair Install Of Windows 7 Is Here
- Collapse -
According to the site, I won't be able to...

...use the repair installer because my DVD is of an older version of Windows 7 (no updates). Is this true? I don't want to mess up my system to the point where I have to nuke & reinstall.

Thanks for the help Grif.

- Collapse -
Also, is there a way to see a list of services...

...without services.msc? It doesn't work without the missing DLL.

Thanks again.

(Sorry for the double post)

- Collapse -
Try "msconfig" From A "Run" Line

The Services list should be available by typing "Run" in the "Search" line and when the Run line utility loads, type: msconfig, then click on OK. There should be a "Services" tab.

As to an "older" version of Windows 7, what "older" version are you referring to? Since there have been no service packs released yet, as long as you have the correct Windows 7 DVD version regarding Professsional, Home Premium, etc., it should work just fine.

Hope this helps.

Grif

- Collapse -
Got all the info I need

The "older" version I am referring to is the Windows 7 DVD without all the latest updates. If the DVD will work without updates, then I guess I'm good to go.

Msconfig didn't work (same error), but I figured out another way to see the services that matter - Sysinternals Autoruns.

Thanks for all the help Grif - you're a lifesaver.

CNET Forums

Forum Info