General discussion

Memory allocation error. What is it?

My ASUS P4p800-se MB has four memory slots. I purchased a gig of Kingston HyperX(2x512) for the blue slots. I received a gig of Crucial Ballistic ram for Xmas for the other two slots.(2X512). The computer seems to run fine most of the time except for a few little annoyances sometimes. Lately I have noticed that it takes for ever for my machine to POST.( I'm talking around 90 sec. or more just to count the ram)! At first I thought it was hung on the ASUS/Intel splash screen because I have to press Tab or Del to see what is going on behind it, which usually doesn't work. Come to find out, I just wasn't waiting long enough. It never does give the POST beep btw. Then it goes into Windows XP Pro SP2 just fine. I happened to run CheckIt Diagnostics and found that there are "memory allocation errors". The only way I can get rid of the errors is to remove the second 2 sticks. I've swapped the sticks around and I even tried a gig of generic ram but I still get the error if the second pair of sticks are installed. What does this mean and will it cause any problems or can I just ignore it and use all 2 gigs of hotrod (ie expensive) ram?

Thanks: Mark

MB- ASUS P4P800-se,
Processor-P4 3.2 gig
Windows XP Pro sp2
Memory- 2 sticks Crucial ballistic(2x512) and 2 sticks of Kingston HyperX (2x512) to fill all slots.
Hd -2 internal and 1 external.
Video- ATI Radeon X700 Pro, 256mb
Sound- Creative Audigy 2 ZS Platinum
Liteon DVD burner
Liteon CD burner

Discussion is locked

Follow
Reply to: Memory allocation error. What is it?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Memory allocation error. What is it?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
you don't have a ram problem

checkit's "memory allocation error" is a software problem in checkit... it is not an indication of a hardware problem. try downloading everest (http://www.lavalys.com/) and use its memory tester.

it takes a while to count and test 2gb of ram. you can skip the mem test by enabling "quick boot" in the bios boot menu.

- Collapse -
Not a free checker

This website no longer supports or provides the free ver. of their software. I downloaded the trial ver. but almost everything useful is disabled.
If the Memory allocatation error is software related then why is it always only on the same 2 slots and not all?

Thanks: Mark

- Collapse -
everest ultimate trial does allow memory benchmarking

Benchmarks are the last item. If the read/write benches run successfully, then your RAM is fine.

As for the error, your version of CheckIt simply may not know how to handle more than 2GB of RAM.

Bottom line: I don't think there's anything wrong with your RAM.

- Collapse -
There's the clue.

"for ever for my machine to POST"

Since this is fully controlled by the BIOS, it means that either the memory is incompatible or the BIOS may have an update to recognise or fix the startup issue.

I'd check for a BIOS update.

Bob

- Collapse -
Thanks for the response!

The memory must be compatible or it wouldn't boot or add up right?
Both types of ram were suggested by the manufacturer's ( both Crucial and Kingston) Ram advisors. All four sticks appear to match up exactly accept for brand name.

Thanks: Mark

- Collapse -
"The memory must be compatible or it wouldn't boot or add up

"The memory must be compatible or it wouldn't boot or add up right?"

Sorry. No. I'll not dive into the deep reasons why this is so.

Bob

- Collapse -
Two things

As suggested go into the BIOS and under BOOT... make sure "Quick Boot" is ENABLED.

Re the RAM....I'd get a current version of Memtest86+
and run it for several hours and see what results you
get.

If that doesn't work...you might consider a BIOS update...but try 1 and 2 first.

VAPCMD

CNET Forums

Forum Info