PC Hardware forum

General discussion

Maxto Onetouch Mini III 80gb, not opening

by MAndreag / October 22, 2007 6:33 AM PDT

Hi. I am on a Gateway Computer, running Windows XP2

I was having issues with my computer so I purchased a Maxtor Onetouch Mini III 80gb external HD. I backed all my information on to it, and reformatted my computer. I had tons of pictures mostly.

My computer is finally back to normal, but now my Maxtor isn't working.

I was working fine, and I could see the drive when connected and access all my files. Then one day. Nothing.

The light at the front keeps flashing when connected, and it freezes my entire computer.

If I go into disk manager, I can see it in disk drives and USB Mass Storage but can't access it.

I've tried the chkdsk g:/f, it says drive not available for direct access.

I also tried PCInspector. When it's searching for the drive, it just hangs there, last time for about 2 hours. Until I disconnet the drive.

It's not very large maybe about 30gb worth of info, but I desperately want to access them, especially my only backup of priceless photos.

Is there anything else I can try at this point?

Discussion is locked
You are posting a reply to: Maxto Onetouch Mini III 80gb, not opening
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Maxto Onetouch Mini III 80gb, not opening
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
That's not backup.
by R. Proffitt Forum moderator / October 22, 2007 6:38 AM PDT

That's a copy and you reduced it to just one so where is the "backup" copy?

While you ponder that consider that most installs of XP overlook the all important motherboard drivers. I'd supply you a link to such but your post left off the details (those words in red.)

Tell more and try the rear USB ports of the desktop machine. DO NOT RUN ANY CHKDSK or other tools because you are more likely to erase the drive as it stands now.

Bob

Collapse -
Okay.
by MAndreag / October 23, 2007 4:02 AM PDT
In reply to: That's not backup.

Okay, I get I didn't really "back-up" my info. Then I guess I simply copied them onto a Maxtor One Touch Mini III 80gb.

My computer has been reformatted, so the pictures and files are no longer on the computer, just a copy on the Maxtor, which I cannot access.

I tried the USB in back of the desktop. I'm not sure what other info you need about my computer. I'm on a Gateway, running Windows XP SP2.

Collapse -
Now I have Gateway but no model number.
by R. Proffitt Forum moderator / October 23, 2007 4:08 AM PDT
In reply to: Okay.

Some required drivers to get the USB ports working proper. I dropped a hint the model number was required for me to note which driver but I wasn't blunt enough it seems.

So here goes. Please tell me the make and model of the machine.

Bob

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.