Question

Magic Mouse not pairing in Windows 7 after pairing in OSX.

Despite what you may think from reading the title I HAVE searched google for a couple months now and I have not seen any similar situations with solutions.

Backstory: This mouse originally was used on a Clevo M590KE (HyperSonic AX20) with Windows 7 64bit which died after 6 years. I got handed down a MBP 3,1 and tooled around with OSX a bit(fresh install of 10.7) and of course connected my Magic Mouse. But being a windows user I quickly got frustrated with OSX for various reasons. It's now wiped and boots only Windows 7 64bit with Bootcamp 4.0 for drivers.

Now: I cannot pair my Magic Mouse. I turn it on, go into window's bluetooth pairing dialog, It shows "Mouse" or sometimes "admin's Mouse" (the username from OSX), I double click that to pair and it just sticks at "Connecting..." and of course the Mouse turns off from pair mode because it took too long.

Questions: Obviously the mouse remembers the Mac it was connected to. Is there any way to reset the Magic Mouse itself? I've tried a lot of things including leaving the batteries out for a very long time(at least a week) but I assume its written in non-volatile flash because that didn't work.

Thanks so much for any help.

Discussion is locked
Follow
Reply to: Magic Mouse not pairing in Windows 7 after pairing in OSX.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Magic Mouse not pairing in Windows 7 after pairing in OSX.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Just a check.

Did you install the drivers after you bootcamp installed Windows?

Also, some folk try to use the Windows from their old (Clevo) and that's a source of troulble. Tell exactly what Windows this is and where it came from.
Bob

- Collapse -
Requested clarification

Clean install of Windows 7 64bit Ultimate (6.1.7601) on the MBP, though I don't know what version I had installed on my old laptop it was most likely the same Windows but not SP1.
By Bootcamp I meant the package that installs all drivers, but it doesn't really matter since the mouse doesn't connect for it to even register the drivers to the device.
More clarification, this laptop had only two partitions on the hard drive: the Main windows partition and the 100mb partition that windows 7 makes so boot camp doesn't do anything except giving me drivers and the keyboard functions.

- Collapse -
And did you see if prior discussions helped?
- Collapse -
Did not help

I have passed up that thread already because i have already done everything in that thread.
The problem isn't my computer its the mouse itself in a new state it doesn't have the users name written to it.

One other thing I have tried was suggested by other threads for a completely different problem was switch the Bluetooth driver to "Apple Built-In BluetoothDFU" which didn't fix it. It's as if the mouse itself is refusing connections to anything that isn't the mac it was last connected to. I cannot pair it to my Asus TF300T or my HTC Vision/Desire Z which both have 4.0 and show that it is a Mouse.

- Collapse -
You do know that Apple Bluetooth is unlike all others?
- Collapse -
I was not aware

I dug around in my box of gadgets and found a usb bluetooth adapter. plugged it into my MBP and now the mouse connects. So now that i know its the bluetooth adapter what do I do to make the internal adapter work with the mouse?

- Collapse -
Ask Apple about drivers for that.

Under Windows it's their drivers. That BT adapter side steps a lot of this and if you have the generic BT adapter, the native windows drivers step in.

In other words you head to the genius counter and let them fix it. Be sure all your files are safely backed up a few times.
Bob

- Collapse -
Answer
Connecting to previously paired bluetooth mouse in BootCamp

Several people have had the problem you describe about pairing a bluetooth mouse in bootcamp. In my situation I could see my ACER bluetooth mouse during bluetooth 'Add Device' procedure in Windows7 Ultimate 64-bit but after selecting the found device and clicking NEXT received infinite 'connecting to device' message. The connection was never successful.


SOLUTION:


In my case I had the latest Apple Inc. Apple Broadcom Built-in bluetooth driver version 4.0.0.1 dated 4/27/2011. The problem (I suspect) was that the mouse itself had some permanent pairing information that could not be erased which was blocking pairing. My fix was to use a separate MAC OS based laptop to pair to the mouse (which worked), then I took the mouse (whilst still paired to the MAC OS but possibly out of range) and paired it with the Windows7 machine. That pairing was successful.


Best Wishes,


bradiko

- Collapse -
Answer
This works

Had the exact same problem - this solution works:
http://youtu.be/2T291O6m7Sk
It is essentially to:
- plug in another mouse
- disable trackpad in device manager
- discover the magic mouse - right click on properties and click box to load drivers
- let them load - magic mouse will work (without scrolling)
- enable trackpad again

My addition to the youtube video:
Download this driver for battery gauge and scrolling:
http://www.trackpadmagic.com/images/stories/download/Mouse-Utilities-Setup-11.exe

Hope this helps someone!

CNET Forums