Mac Desktops forum

General discussion

Mac Pro suddenly not recognizing discs

by runcapher / September 28, 2010 1:15 AM PDT

Hi all. Hopefully this is the correct place to post my question. Yesterday I inserted a movie DVD into the internal drive of my MacPro 3,1 and received the error message, "The disc you inserted is not readable by this computer". I tried several different movie discs, some old, some new releases I just purchased and I get the same message. Data discs work fine but not movie DVDs.

I also noticed that my Mac can no longer mount an ISO or DMG file. I get an error saying "No Mountable filesystems". I have repaired permissions, restarted, disconnected all external peripherals, etc. Pretty much all the basic stuff you try when your Mac isn't behaving as you'd expect. The odd thing is that it just started behaving this way within the last two days. DVDs played fine before and I could mount any ISO or DMG file. Only thing that is different is I ran the most recent security update from Apple when it popped up. Would welcome your thoughts, suggestions, etc.

Discussion is locked
You are posting a reply to: Mac Pro suddenly not recognizing discs
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Mac Pro suddenly not recognizing discs
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
That MacPro.
by mrmacfixit Forum moderator / September 28, 2010 5:29 AM PDT

Boot from the Restore disks or from an OS X installation disk and run Disk Utility and Repair Disk.
If all is well, and the problem still exists, consider the following:
1. Delete the Finder Preferences. You will find them in your Home Folder>Library>Preferences. com.apple.finder.plist Just drag it to the desktop and reboot.
2. Archive and Install of the System using the OS X installation disk.

P

Collapse -
Thank you!
by runcapher / September 28, 2010 5:33 AM PDT
In reply to: That MacPro.

I'll give it a try. Thanks for the post. Will let you know how I make out.

Collapse -
Problem still exists
by runcapher / September 28, 2010 10:18 PM PDT
In reply to: That MacPro.

Well, tried all of the suggestions provided and still cannot get my MacPro to mount a movie disc. I really think it must be software related because movie discs will not mount in my internal SuperDrive or the two external Sony DVD writers. Any other thoughts?

Collapse -
(NT) Even after performing suggestion #2?
by mrmacfixit Forum moderator / September 28, 2010 10:57 PM PDT
Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?