Mac OS forum

Question

Mac Network Lock unlocks itself!

by bionicjules / July 6, 2012 8:15 PM PDT

My Mac OSX 10.5 is connected to the Net wirelessly via an Apple Airport Express, with the Network Preferences lock ON.
But after restarting after overnight shut down, the Lock Is OPEN and the network has reverted to the provider's default, in this case "Fon Zon Free Internet" (not free!)
How is the lock being unlocked ??

Discussion is locked
You are posting a reply to: Mac Network Lock unlocks itself!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Mac Network Lock unlocks itself!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
not sure what is causing this but,
by mrmacfixit Forum moderator / July 6, 2012 11:08 PM PDT

what do you mean by "providers default"?

What do you have it set for when you lock it?

Have you ever been back to the Network Preferences after you have locked it but before you shut down for the night?


P

Collapse -
Can't Lock Network Choice
by bionicjules / July 7, 2012 2:37 AM PDT

The network provider is Zon Portugal. The network list in order of preference show's my name i.e JB's Network as 1st choice at the top - LOCKED!
Below that is "Fon Zon Free Internet", then "Zon-3F90". I've tried to delete 2nd and 3rd from the list, but it doesn't appear possible. Hence my use of the word "default".
As long as the computer is running, there's no problem. But recently - to start the day on max free memory - I've been shutting down overnight.
In the morning, or whenever I shut down, networks preferences appears UNLOCKED and the 2nd UNWANTED network is selected. (This effectively means NO internet connection). So it has to be re-set by me in Networks Preferences when I - or any 3rd party - want to go online. Any idea how come the lock UNLOCKS if not authorised by the administrator (me)?

Collapse -
Go to System Preferences,
by mrmacfixit Forum moderator / July 7, 2012 10:49 AM PDT

Network,
WiFi,
Advanced.

There you will see a list of wireless networks that are stored in your machine.
Select the one(s) that you do not want then hit the "-" (Minus) button
Do them one at a time until you have the one you want as the only remaining network

Now put a check mark in the "Require administrator authorization to: Change Networks line.


Give that a whirl

P

Collapse -
Woohoo!
by bionicjules / July 7, 2012 8:15 PM PDT

Woohoo! Thanks! It worked, though only after re-typing "Apple Network 9aa 2bft" below my "JB's Network" in Advanced.
The only (minor) irritant now on re-booting is reversion to unnecessary maximum screen brightness, which I can't seem to override, so always manually reset to minimum.
Thanks again.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?