Question

Mac keyboard is typing extra letters

Oct 8, 2018 1:00PM PDT

I have a Mac running OS X Yosemite, version 10.10.5
The keyboard recently, inexplicably started typing extra letters.
For example, when I type "now," what appears is "bnow." When I type "the," what appears is "tyghe."
I tried using a different keyboard, to no avail. Also tried rebooting in safe mode, which did no good.
Can't find any solutions online, so I guess I'll have to lug it to a repair shop. Sigh.

Discussion is locked

Answer
Follow
Reply to: Mac keyboard is typing extra letters
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Mac keyboard is typing extra letters
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Tell more.
Oct 8, 2018 1:38PM PDT

Was the other keyboard some USB keyboard or Bluetooth or ???

When the USB or such keyboard does this it's usually software.
When the replacement keyboard does this, it could be hardware such as a bum motherboard.

Let's hear exactly what the test was.

- Collapse -
Answer
Any solution?
Aug 13, 2019 2:53AM PDT

Hey @mauschunque,

What was the solution to this issue? My mac started doing this a couple of days ago too. Nearly locked me out because it happened on the login screen

- Collapse -
Answer
Damaged Keyboard?
Aug 29, 2019 4:49PM PDT

If your example is a real example, note the physical location of the b and the n - they are next to each other. Same for the extra y and g when you try and type "the." Those letters are all neighbors trying to horn in on the action. This could be damaged caused by liquid, or their could be a little dirt, or a few sand causing more than one key to depress at a time. This advice might be a little late, but hopefully helpful to some having a similar issue: try some canned air and blow it through all those keys.
Macs are like Swiss watches and there's not much tolerance between the few moving parts. Keep it clean and it will server you well.

Plexus IT

Site promotion removed by Moderator

Post was last edited on August 29, 2019 5:06 PM PDT

- Collapse -
Answer
Mac keyboard is typing extra letters.
Jan 13, 2020 2:33AM PST

Hi

It’s simple settings change either way and thus is worth a try, here’s what to do:
- Pull down the  Apple menu and go to “System Preferences”
- Go to the “Keyboard” preference panel, and choose the Keyboard tab
- Locate the “Key Repeat” slider setting and adjust it to the “Off” position
- Exit out of System Preferences
- Open any typing application (TextEdit, Word, Pages, etc) and try to replicate the double-typing issue by typing sentences and phrases, as usual, the double space and double typing issue should be resolved.

Thanks
Guru Computers.

- Collapse -
If this was a response to a repeating key problem,
Jan 13, 2020 6:49AM PST

It would have been useful.
However, given that the question was about a keyboard that was typing extra letters, not repeating letters, it was not.
Not exactly the sort of answer one would expect from poster using the name "Guru Computers"
P

CNET Forums

Forum Info