Change the setting for your Screensaver.

Select any area of your desktop, and right-click;
select [Properties];
on the Display Properties sheet, select the "Screen Saver" tab;
For WinXP you will see the:
"On resume, display Welcome screen", uncheck it.

Note: for other versions of Windows you may see some other sort of selection, something like:
on resume require password, or
Password required, something like that;
just uncheck that, whatever it is called.
(Depending upon the wording you might have to check it, instead, ... whatever)

Then click the [OK] button. That should do it.