Samsung forum

General discussion

LN52A650 has no picture

by garp926 / November 16, 2008 11:58 AM PST

I was watching a HD channel the other night and switched to a standard def channel and my picture disappeared. The screen has a light orange color now. All the channels are like that. The audio still works, and the menu still comes up, just no TV image. DVD player comes through with component cables ok. My hook up is an SA 8300HD box through HDMI cable. I tried connecting it through the side input, but no image. The side input worked fine with my digital camera though. I don't think its the cable box since the channel info and everything else seems to work on the box, but I'm going to swap it out tomorrow anyway to make sure. Any ideas on what is wrong or needs to be replaced? The main board was replaced 5 weeks ago. Since then, a few times I've lost the picture or had a picture that looked like an x-ray when going from a 1080 to 480 res. channel. When I'd change channels it would go back to normal. Any thoughts are appreciated

Discussion is locked
You are posting a reply to: LN52A650 has no picture
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: LN52A650 has no picture
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Probably not the same problem
by Crewmax / November 18, 2008 1:41 AM PST

I had an occasion where I lost my picture. My Direct TV DVR is the signal source. I still had program menu. I re-booted the DVR and regained my picture. Like I said, probably not your issuse, but it doesn't hurt to share. Good luck!

Collapse -
Fixed it
by garp926 / November 18, 2008 3:59 AM PST

I tried the same thing yesterday and it worked. I was going to swap the box before I made a service appointment, just to make sure. I rebooted it before I took it just to see, and the picture came back.
Thanks for the information. I think I'll still swap it out but I'm glad I don't have to go through the hassle of getting the tv repaired.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?