General discussion

LN46B750 Network Tests Failing

Greetings,

Internet access was setup and working fine until I changed the IP addresses of home network.

Setup:

Comcast for internet access
LinkSys WRT350N Router (DHCP server as well)
current IP of router 192.168.24.192 (previous 182.168.1.1)
Subnet Mask: 255.255.255.224 (previous 255.255.255.0)

In Network setup, when I set the TV to "auto" mode I get:

MAC Address ... good
IP Address, Subnet, Gateway, DNS Server ... failed

The network configuration (IP) is not valid. Check the network settings and enter a valid value before trying again.


If I set the TV to "manual" with the following information:

IP: 192.168.24.194 (previously was 192.168.1.4)
Subnet: 255.255.255.224 (previously was 255.255.255.0)
Gateway: 192.168.24.192 (previously was 192.168.1.1)
DNS: 68.x.x.x <-- provided by comcast (did not change)

This fails at Domain Ping:

Connecting to external device failed. Please contact your network service provider.

Other devices can access the internet fine. I've reset the modem and router a dozen times. Even left the TV unplugged for an hour.

Recall that this was working before with a statis

Questions:

Does anybody know what server the domain ping is trying to reach?
Is there a way to reset the network?
I've read about a service menue but the key presses didn't work for this tv.

Thanks in advance!
Brian

Discussion is locked
Follow
Reply to: LN46B750 Network Tests Failing
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: LN46B750 Network Tests Failing
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Odd choice of IP and mask.

TCPIP/IP configurations can be rough on owners. Why not go back to what works? Or at least a standard 255.255.255.0 netmask.

- Collapse -
Agreed but ...

Hi R.Proffitt,

I needed to change it to allow other network devices the ability to see the local LAN while connected to a corporate VPN. In order to remain connected to the VPN and see devices on my home networks (storage/printers/etc) I must use this range/subnet.

However, I think one would agree the network is valid so why does the TV not obtain a new address in auto and fail the Domain Ping in manual?

Thanks,
Brian

- Collapse -
Additional info

I'll add that the router hands out the 192.168.24.x address as the TV requests it but is seems the TV doesn't do anything with it.

- Collapse -
The netmask is still an option.

Not to dive into a discussion about that but that is what I'd change first.

- Collapse -
Where to make the change?

Where are you suggesting I change the mask back to /24 on the TV, the router, or both?

- Collapse -
Your suggestion worked

I changed the mask back to /24 on the TV and it connected. I'm still not sure why. But it worked.

Thanks for the suggestion.

- Collapse -
Subnetting

If you have a subnet of 255.255.255.224,
strictly speaking IP 192.168.24.192 should not be used, as it is reserved as the Network Address for that subnet. The TV might determine that the network is misconfigured, but other devices don't care, as they don't ping the Gateway. Not sure...
With your subnet mask, the following IPs should not be assigned:

192.168.24.0
192.168.24.31
192.168.24.32
192.168.24.63
192.168.24.64
192.168.24.95
192.168.24.96
192.168.24.127
192.168.24.128
192.168.24.159
192.168.24.160
192.168.24.191
192.168.24.192
192.168.24.223
192.168.24.224
192.168.24.255

- Collapse -
^^^ Correction

Line 1 of my previous post should read
"If you have a subnet MASK of 255.255.255.224"

- Collapse -
Thanks for the info.

I forgot about the network address and used it as the gateway. That could very well be it.

Thanks again.

- Collapse -
See that next reply.

With the restricted netmask your gateway is not on the lan. So it should not work.

There are netmask calculators out there but I leave such things to others.
Bob

CNET Forums

Forum Info