rocmerbay,

There is probably a setting in the DVD player's menu that you have to change. Keep an eye out for options for "Interlaced" or "Progressive". If you get that option, opt for "Progressive", and you should see your 480p signal displayed on the INFO bar.

--HDTech