General discussion

LN-S3241 Pixel issues?

Hello,
I've had this tv a few years now, just recently something weird has happened. I noticed a black strip at the top left corner of the TV. At first I thought this could be a burned out pixel issue, however the angle of it is very strange, it looks like more something has fallen behind or infront of the LCDs blocking the light from coming through. I'm posting a link to a picture of the problem. I've tried to talk to Samsung about it, but they don't seem to get the problem. If I'm correct, and something has fallen behind the LCDs, is it easilly fixed?
http://tinypic.com/r/2w3qcdd/5

Discussion is locked
Follow
Reply to: LN-S3241 Pixel issues?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: LN-S3241 Pixel issues?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
LN-S3241 Pixel issues?

greggk1,

Indeed, that is odd for an LCD panel. It almost seems like something internal has collapsed, or like you noted - something fell inward. Without knowing either way, it's hard to determine how easy - or inexpensively - it can be fixed. I can't even offer a diagnosis.

Have you been able to send this link or picture in to our service center? It's out of warranty, but it can't hurt to ask.

--HDTech

- Collapse -
LN-S3241 Pixel issues?

No, I've tried sending it to one of the techs before, but they keep saying that they did not receive the image. I will try to find a service center here and try to send it to them see what they will say.

CNET Forums

Forum Info