General discussion

'Live" O.S. on flashdrive

May 13, 2018 7:44PM PDT

Evening:

I used to run Linuxmint 17.3 'live" frorm an 8Gb. flashdrive. Got along fairly well. Got a bright idea a little while ago and thought I should upgrade to 18.3. Well, I've not been able to get a "stable" O.S. since! I've tried 6 different Linux/Ubuntu flavors on 5 different USB pendrives. ALL O.S's have had major lagging issues. OK, first, I've run every test you could conceive on those pendrives searching for anything corrupt...every drive ran every test and passed. I'm certain there is nothing wrong with the drives. The lastest drive I'm trying the O.S's on is a Lexar 16Gb-3.0 that's less than a y/o. Now, all the distros seem to boot up OK but after that every one has major lagging issues. I'm talking like 4 mins. to load a browser, D/l'ing anything is a lesson in futility , instaling anything?...well I could grow a beard faster!!! I never had any of these problems with 17.3 and the only reason I don't go back to it is that I can't get the browser I want with that edition. I used pendrivelinux to configure the iso's and make the drive bootable. Funny, when I D/l an .iso and tried to use Unetbootin, it wouldn't load and/or execute any of the lastest distros?? OK, hope I've given enough info(?). I really want to solve this and get back to running Ubuntu/Linux. What the heck is causing the problem with the distro's excessing lagging/freezing issues? My guess is it has something to do with the way the O.S's are being loaded by PDL installer, but then, that's just my guess and still I don't have a clue as to what to do about the issue.
BAFFLED:
Confused Rick

Discussion is locked

Follow
Reply to: 'Live" O.S. on flashdrive
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: 'Live" O.S. on flashdrive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
I'm going to have to try this.
May 13, 2018 7:48PM PDT

I usually run TAILS on USB with others for repair and access to busted OS PCs.

Thanks for this, I'll try it in a few days.

I only have a measly i7 8 or 16GB RAM laptop to test on so here goes.

- Collapse -
AFter 17.3
May 14, 2018 5:22AM PDT

Something seemed to break Unetbootin for linux mint after 17.3 and the best one to use for creating LIVE with persistent USB flashdrives now is mkusb program. You didn't mention the flashdrive models used, but many, even the USB3, are only 5 mbps write and about 15 mbps read, and of course those will lag. When using mkusb program however, it will also create a boot option of TORAM, which will load everything into RAM, bypassing the USB flashdrive and it's slower speed then. One of the more popular, yet inexpensive, USB flashdrives used for LIVE with persistence is the Samsung 150 mbps/read, 40 mbps/write, keychain flashdrive for $20 for 64GB. Or can pay $14 more and get one already set up on same flashdrive.

Since you are familiar with linux now, you can run a benchmark speed test on the flashdrives you are currently using from the disks program on many distros, and I know it's also in Mint linux.

- Collapse -
"Live" O.S. on flashdrive
May 14, 2018 10:37AM PDT

RE: JamesDenison

Did not know about unetbootin problem, but I also have the same problem w/ pendrivelinux. And I agree with you in as much as I didn't experience problems w/ 17.3, but it all started when I "upgraded" and now, can't get anything(including 17.3) to operate correctly. As I agree there will be some inherent "slowness", what I've experienced is beyond tolerance and is not what a properly running O.S. (even live) should be doing. I did mention the flashdrive I'm currently using. Ahm..not being a smartass, but why would I buy an distro when I can D/l and run on a drive I already have? Last: with all the tests on all the drives I've used, the brand/model is rendered irrelevant. I'll re-state: I do not believe the drives (all 5) are the problem! Thanx for responding
Devil

- Collapse -
let us know
May 14, 2018 2:07PM PDT

how it works out using mkusb on those flash drives. I leave one made, also persistent with casper-rw, using mkusb, plugged into a second computer I have for my wife and daughter to use exclusively for online purchases, which is mint 18.? and no problems.

CNET Forums

Forum Info