TVs & Home Theaters forum

General discussion

LG BD-390: Unable to connect to Netflix/CinemaNow/YouTube

by Haggisdog / January 1, 2010 10:19 AM PST

I purchased a BD-390 a few weeks ago and have been struggling with getting the wireless video streaming to work properly. I've been on the phone with LG and with my ISP and neither have been able to help.

The problem is while I can configure the LG to access the internet (the test connection confirms I'm connected to the Internet), I am unable to connect to YouTube/NetFlix or CinemaNow. However, I can connect to Vudu and I have been able to stream a HD movie and watch trailers using Vudu, I can also connect to the other computers on my network (at least I can see their directories).

I've tried the internet connectivity with both Wired and Wireless with the same results. I have a 16Mbps cable connection from Comcast and although I do have VOIP and a few other computers on this network none of them are using any bandwidth while I've been trying to get this to work. I'm currently running Wireless G as my wireless network but when I ran a dedicated ethernet connection I had the same problem.

I'm on the verge of returning this but thought I would ask if anyone else has any ideas or suggestions before I do. Thanks for any help you can provide.

Discussion is locked
You are posting a reply to: LG BD-390: Unable to connect to Netflix/CinemaNow/YouTube
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: LG BD-390: Unable to connect to Netflix/CinemaNow/YouTube
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check you firewall & router settings
by Pepe7 / January 1, 2010 1:26 PM PST

That will likely solve your dilemma.

Collapse -
LG-B390: Router Settings
by Haggisdog / January 2, 2010 1:28 AM PST

Thanks, I looked the router settings previously and didn't see anything out of the ordinary (I'm using a Linksys Wireless G router), most, if not all, of the settings are right out of the box. I'll try a firmware update and maybe reset everything to see if that helps.

Collapse -
Also check the user comments @ Amazon
by Pepe7 / January 2, 2010 6:21 AM PST

I noticed the reviews there sometimes have good specifics on troubleshooting devices like yours.

Collapse -
AVFORUMS
by Haggisdog / January 3, 2010 9:29 AM PST
In reply to: Also try AVS

Thanks for the link, I posted there too.

Collapse -
Same exact problem...
by juniormoua / January 9, 2010 9:26 AM PST

I just bought mine about 2 wks ago (Christmas week) and have the same exact problem. Network shows that it is stable and good. Vudu streams perfectly in High Definition without a problem, but the others like Netflix, Youtube, Cine, are all conjested/not connecting. Somehow the wireless issue is a big problem for these programs other than Vudu... and there's still no solution yet. Please follow-up if there are any news as well.

Collapse -
LG BD-390 Connectivity Problem Solved!
by Haggisdog / January 10, 2010 11:39 PM PST
In reply to: Same exact problem...

I was able to fix this problem this weekend by disabling the DHCP assignment and hard-coding the IP Address, Gateway and DNS Servers directly into the BD-390 (this is part of the network setup set of screens). It fixed the problem immediately and I've been able to access YouTube, NetFlix and CinemaNow.

Hope that helps.

Collapse -
How Input IP Address?
by rcawood / January 31, 2010 10:25 AM PST

I have the same problem.

How do you manually input numbers on the IP screen? I select Manual and can cursor around the fields but can't figure out how to input numbers.

Collapse -
Remote Pull Out
by rcawood / January 31, 2010 10:32 AM PST
In reply to: How Input IP Address?

I found it. Bottom cover of remote pulls down to reveal a keypad.

Collapse -
Still Won't Connect
by rcawood / January 31, 2010 10:38 AM PST
In reply to: Remote Pull Out

But setting the a static IP, etc. did not work for me. I still have the same not connecting problem.

Collapse -
Another Solution
by juniormoua / February 1, 2010 12:31 AM PST
In reply to: Same exact problem...

I found another solution that fixed the problem. I updated the firmware of my router AND then my cable modem. After both of those firmware were updated, everything worked fine for me as well. I was able to access everything now with ease. Hope this solution also helps.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?