Question

Lenovo G50-80 Laptop with a Broadcom 802.11n network adapter

I never had a problem with the adapter when I had Windows 8.1, but now with Windows 10, it disconnects quite often and I have to reconfigure the adapter. What can I do to stop this?

Discussion is locked
Follow
Reply to: Lenovo G50-80 Laptop with a Broadcom 802.11n network adapter
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Lenovo G50-80 Laptop with a Broadcom 802.11n network adapter
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Too vague. But

Last week I fixed one like that. They had forget to check the box "always connect."

- Collapse -
There is no box to check...

it is either connect or disconnect when selecting a network. I remember with Windows 8.1 there would be a box to check to "always connect".

- Collapse -
You're right. The words did change on the check box.
- Collapse -
Therefore...

I still have a problem with staying connected wireless to the network I use since the box is checked.

- Collapse -
Next up.

1. Check with the laptop maker for driver update. Worth repeating. Microsoft's driver update is still junk.
2. Be sure the distance is not too far and signal is good. I use an Android WiFi Analyzer to check out the area.
3. Be sure to not use MAC filtering on the router.
4. Be sure to not use WPA/WPA2 on the router. Pick WPA2.

- Collapse -
Re: Next up

1. I use Driver Booster 3 to check the latest updates and all drivers are up to date.
2. The computer is 15 ft. from the router.
3. I do not use MAC
4. I have been using WPA2 for years.

Again, I never had this problem when I was using Windows 8.1 or 7 for that matter.

- Collapse -
At this point I have to leave.

I never used any of the driver boosters because they don't work for me. I have to leave you to Driver Booster's support.

- Collapse -
I did some research...

I googled my problem and I came up with a possibility of fixing the problem. This person had the the same problem, so he went to the properties of the adapter and clicked on "configure device" button. Under Power Management tabthere is a statement saying: "Allow the computer to turn off the device to save power" with a check box next to the statement. It was recommended to remove the check mark and save. The person did not have the problem afterwards. I did exactly that and I will see what happens hoping this does solve the problem.

- Collapse -
go into router settings

try going into your router settings and see if there is a firmware update. In addition did you go to levovo's website, search for your specific model and see if there are any updates there. DO NOT USE driver booster for this. Do it yourself.

- Collapse -
Lenovo's website...

I checked the latest update for the adapter and I have the latest driver for it according to the website. I will look into the settings for the router.

- Collapse -
check the lease setting in the router

May have changed. I sorta doubt that's it, but won't hurt to be sure. See DHCP area.

CNET Forums