Computer Help forum

General discussion

Laptop wont boot up after installing new memory

by ry83 / August 27, 2008 10:35 AM PDT

Hey everyone just have an issue i need some help with...

I have a toshiba laptop x205-s7483 and i upgraded from 2 gigs of memory to 3 ( had 2 1gig chips replaced one with a 2 gig) that I ordered from toshiba direct so i know that it was compatable, and when i went to turn back on the computer the power button comes on and the hard drive button flashes for a sec but then that is it. the monitor doesnt seem to turn on at all and the only fan i can hear running seems to be the cpu fan. Is there anything you can think of that i can do? btw When installing the new chip i turned off my laptop, unpluged from the wall and removed the battery as the instructions said to do.

Discussion is locked
You are posting a reply to: Laptop wont boot up after installing new memory
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Laptop wont boot up after installing new memory
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
i forgot
by ry83 / August 27, 2008 10:38 AM PDT

sorry i forgot to say that i also put the old memory back in to see if that would fix the issue and it didnt help at all

Collapse -
Sad news.
by R. Proffitt Forum moderator / August 27, 2008 11:52 AM PDT
In reply to: i forgot

I'm finding the new motherboards that use LEAD FREE SOLDER are more fragile than before. Try just one stick of RAM at a time in each socket. If it powers up and runs consider not tinkering with it ever again. Here's why -> The lead free solder is prone to cracking and these memory sockets can be stressed by some owners. The fix is very very expensive.

Collapse -
Wrong ram
by sgopiani / September 13, 2008 11:09 PM PDT
In reply to: Sad news.

well you might have the wrong type of ram because you get ram like DDR, DDR2, DDR3 and others also you get a different number of pind like 64, 128 so you might have the wrong type of ram. TAke your old ram drive into a store and ask them what type it is and get that type.

Collapse -
He says ...
by Kees Bakker / September 13, 2008 11:13 PM PDT
In reply to: Wrong ram

he has a compatible RAM from Toshiba directly. Better read a post before giving the wrong answer.


Collapse -
Did you
by Whitecougar / September 14, 2008 12:07 PM PDT

Install the ram correctly ie. remove the battery, unplug the laptop etc. If not try it to see if it helps.

Collapse -
Think the poster indicated that in the original post..
by VAPCMD / September 14, 2008 1:39 PM PDT
In reply to: Did you

'btw When installing the new chip i turned off my laptop, unplugged from the wall and removed the battery as the instructions said to do.' Sounds like he/she did it right to me..shame the outcome wasn't as expected.


Collapse -
problem solved
by ry83 / September 14, 2008 2:04 PM PDT

Hey everyone thanks alot for your responses they were much appreciated. When I went to the toshiba support site they had a link to just the problem I was having so clearly I wasn't the only person with the issue. So I sent my laptop in and they were able to fix whatever it was and its now up and running. Thankyou again for all your suggestions and ill post the link at the bottom to anyone whos interested about the issue, thanks again!

Collapse -
Glad to hear it's resolved. Thanks for the posting
by VAPCMD / September 15, 2008 12:21 PM PDT
In reply to: problem solved

the outcome.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.